summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Quinn <code@danielquinn.org>2015-12-16 15:36:45 +0000
committerDaniel Quinn <code@danielquinn.org>2015-12-17 01:10:25 +0000
commitc6f1f438fbcb0a81c7474fb05ddc95a45fa545a9 (patch)
tree8ef60263d3c3b8cddda6ce9b3779f6fef75ee092 /www-client
parentsys-kernel/hardened-sources: version bump to 4.3.3 (diff)
downloadgentoo-c6f1f438fbcb0a81c7474fb05ddc95a45fa545a9.tar.gz
gentoo-c6f1f438fbcb0a81c7474fb05ddc95a45fa545a9.tar.bz2
gentoo-c6f1f438fbcb0a81c7474fb05ddc95a45fa545a9.zip
www-client/ripe-atlas-cousteau: Initial commit
Diffstat (limited to 'www-client')
-rw-r--r--www-client/ripe-atlas-cousteau/Manifest2
-rw-r--r--www-client/ripe-atlas-cousteau/metadata.xml10
-rw-r--r--www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.6.ebuild37
3 files changed, 49 insertions, 0 deletions
diff --git a/www-client/ripe-atlas-cousteau/Manifest b/www-client/ripe-atlas-cousteau/Manifest
new file mode 100644
index 000000000000..5f4cfa26d8ee
--- /dev/null
+++ b/www-client/ripe-atlas-cousteau/Manifest
@@ -0,0 +1,2 @@
+DIST ripe.atlas.cousteau-1.0.6.tar.gz 45467 SHA256 1407b003a03f359739d35010812af2841bc9df2784cd2078e55ac34d0a858ad6 SHA512 212c9890af269f945d01a1b587ba87583cbde87ce0a64b09e053644f9fa4cd01414a1092a39d0d21d68b3bd5977e0159c6a32196aaadbd78940fd4675b791daf WHIRLPOOL b65e12a89a3cfee2ca5da4311392a1ecca4fc11c4b38ca911a526cc925491b799d1504581a955dd5bd5c1feb3e71d5a73c06e5b07c26a8fbfdb28bcc748f6a1d
+EBUILD ripe-atlas-cousteau-1.0.6.ebuild 937 SHA256 b8b08a040230a6c3bc45a388c71c0dde74f47894bccfc656066dc0e80c264ca7 SHA512 fefda75c507fe675e44784ed6a0c2045b057288bd68a4ff36a449c7a207bc9c04d8add2112748ff55d4e77c5f8d54c417017fc74958b7c95f5d3d371e670df62 WHIRLPOOL 27ba1bb1b85f7f3b146f5d02924e7158c371500c4766f348232faab031a7a776682227ea4757e9877ef49aa517e15ee1d57e8d9d243c653ec868543f91312b38
diff --git a/www-client/ripe-atlas-cousteau/metadata.xml b/www-client/ripe-atlas-cousteau/metadata.xml
new file mode 100644
index 000000000000..46c572635b0b
--- /dev/null
+++ b/www-client/ripe-atlas-cousteau/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>gentoo@danielquinn.org</email>
+ <name>Daniel Quinn</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.6.ebuild b/www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.6.ebuild
new file mode 100644
index 000000000000..157abbe3aaf5
--- /dev/null
+++ b/www-client/ripe-atlas-cousteau/ripe-atlas-cousteau-1.0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+MY_PN=${PN//-/.}
+DESCRIPTION="A Python wrapper around the RIPE Atlas API"
+HOMEPAGE="https://atlas.ripe.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/ripe.atlas.cousteau/ripe.atlas.cousteau-${PVR}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S="${WORKDIR}/${MY_PN}-${PVR}"
+
+RDEPEND="
+ >=dev-python/socketio-client-0.6.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ "${RDEPEND}"
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
+
+python_test() {
+ nosetests --verbose || die "Tests failed with ${EPYTHON}"
+}