summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-24 16:17:12 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-24 16:17:27 +0200
commitfd7d47b11f9ec6588e91e9d22784b06adcf80132 (patch)
tree1f6ab27804ad4badbccb576747243fc7b3845765 /www-client
parentapp-emulation/docker-registry: Remove old (diff)
downloadgentoo-fd7d47b11f9ec6588e91e9d22784b06adcf80132.tar.gz
gentoo-fd7d47b11f9ec6588e91e9d22784b06adcf80132.tar.bz2
gentoo-fd7d47b11f9ec6588e91e9d22784b06adcf80132.zip
www-client/seamonkey: De-uglify new enigmail code a bit.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'www-client')
-rw-r--r--www-client/seamonkey/seamonkey-2.48-r1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/www-client/seamonkey/seamonkey-2.48-r1.ebuild b/www-client/seamonkey/seamonkey-2.48-r1.ebuild
index e68716cfedaa..01fae8065d91 100644
--- a/www-client/seamonkey/seamonkey-2.48-r1.ebuild
+++ b/www-client/seamonkey/seamonkey-2.48-r1.ebuild
@@ -400,13 +400,14 @@ pkg_preinst() {
die "Could not find enigmail on disk during pkg_preinst()"
fi
if [[ ! -h "${emidpath}" ]] && [[ -d "${emidpath}" ]]; then
- rm -Rf "${emidpath}" || (
- eerror "Could not remove enigmail directory from previous installation,"
- eerror "You must remove this by hand and rename the symbolic link yourself:"
- eerror
- eerror "\t cd ${EPREFIX}${MOZILLA_FIVE_HOME}/extensions"
- eerror "\t rm -Rf ${emid}"
- eerror "\t mv ${emid}.backup* ${emid}" )
+ if ! rm -R --interactive=never "${emidpath}" ; then
+ eerror "Could not remove enigmail directory from previous installation,"
+ eerror "You must remove this by hand and rename the symbolic link yourself:"
+ eerror
+ eerror "\t cd ${EPREFIX%/}${MOZILLA_FIVE_HOME}/extensions"
+ eerror "\t rm -Rf ${emid}"
+ eerror "\t mv ${emid}.backup* ${emid}"
+ fi
fi
fi
}