summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-07-26 19:44:50 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-07-26 19:45:57 +0300
commite2d424b2572d6a0c08b6ec703a78c499ef4d0379 (patch)
tree74344358199bda9d7fb72a8b8e605dcf6f5037ab /www-misc/bookmarksync
parentsys-process/prll: version bump. (diff)
downloadgentoo-e2d424b2572d6a0c08b6ec703a78c499ef4d0379.tar.gz
gentoo-e2d424b2572d6a0c08b6ec703a78c499ef4d0379.tar.bz2
gentoo-e2d424b2572d6a0c08b6ec703a78c499ef4d0379.zip
www-misc/bookmarksync: Revision bump (EAPI=7)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'www-misc/bookmarksync')
-rw-r--r--www-misc/bookmarksync/bookmarksync-0.3.4-r3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/www-misc/bookmarksync/bookmarksync-0.3.4-r3.ebuild b/www-misc/bookmarksync/bookmarksync-0.3.4-r3.ebuild
new file mode 100644
index 000000000000..288100d55459
--- /dev/null
+++ b/www-misc/bookmarksync/bookmarksync-0.3.4-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="bookmarksync synchronizes various browser bookmark files"
+HOMEPAGE="https://sourceforge.net/projects/booksync/"
+SRC_URI="mirror://sourceforge/booksync/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc x86"
+SLOT="0"
+
+IUSE="perl"
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ perl? ( dev-lang/perl )"
+
+src_prepare() {
+ default
+ sed -i Makefile \
+ -e 's|g++|$(CXX) $(CFLAGS)|g' \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
+ tc-export CXX
+}
+
+src_install () {
+ dobin bookmarksync
+ if use perl ; then
+ dobin tools/bookmarksync.pl
+ dodoc tools/README.tools
+ fi
+ dodoc README TODO DEVELOPERS
+}
+
+pkg_postinst () {
+ use perl && ewarn "You will need to modify bookmarksync.pl before use"
+}