summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-09-05 16:32:30 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-09-06 00:46:14 +0200
commitbb541f92e7b248adc7d15f3d4c3500583b6fbbb3 (patch)
treed2ab94e87c91b0be88f52e6c332022c23ece3cc6 /www-misc
parentwww-client/firefox-bin: amd64 & x86 stable (diff)
downloadgentoo-bb541f92e7b248adc7d15f3d4c3500583b6fbbb3.tar.gz
gentoo-bb541f92e7b248adc7d15f3d4c3500583b6fbbb3.tar.bz2
gentoo-bb541f92e7b248adc7d15f3d4c3500583b6fbbb3.zip
www-misc/urlwatch: bump to 2.14, add Python 3.7, drop 3.4
Newer version of the dependencies don't support Python 3.4. Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/urlwatch/Manifest1
-rw-r--r--www-misc/urlwatch/urlwatch-2.14.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/www-misc/urlwatch/Manifest b/www-misc/urlwatch/Manifest
index 3419d2882fa6..ed08dc67dd9d 100644
--- a/www-misc/urlwatch/Manifest
+++ b/www-misc/urlwatch/Manifest
@@ -1,3 +1,4 @@
DIST urlwatch-2.13.tar.gz 34312 BLAKE2B 6ac618d4f1f78b0a3f6d17dd2283704e8d1fc7173ce6d79fcf0f9177f48463a610a4c20d8483a4a9c22e56eca67730ef25982981f310ca8e9927e48e298a1b1d SHA512 5ca6ad3de54c2e1d63cb545ae0d213a4483ef175dad947be00994bc990d047c7aec1f3b0a8b23290672db940001a9cc31c919aa7d9c280ab4792299e2dba684c
+DIST urlwatch-2.14.tar.gz 36587 BLAKE2B 6c4115c58cc9aae5ac8c62f7cb360ca38afa9a9ceadc93f3c9d2bccc7808ab1accf912a0f5756d984bb7a33fa448c91c1bb90e841bd45e2f8d34c4d74cae531c SHA512 8c7b479f80973da28e281e8437a30038c6dcdf9036c30cb5e685fdb9460fbb7b90a27e9d5a27290cfe30de1a0f443644b13c8a10740c205ebd58bcb2bb29c888
DIST urlwatch-2.5.tar.gz 25322 BLAKE2B 637fa254fe565d9a3909fc80879a7b40a72a92e01cdca3a2e95f905c768238e4a2ef7559e32ae4295357d3391109f08149e721564e4c14b6c8be281a416cc45a SHA512 993d2596288d014a3b84ae22c29ce89282c4320dd95b339c9892db07997059fc80a96198cb89ba04d935f68d2d051da96dc981f8e8b3657492443b060d2126a1
DIST urlwatch-2.6.tar.gz 30412 BLAKE2B 3d9495a418f8180a788db27bec13f9c20d92476851404d0f78dc6fec664a90c4bf9749cbe26323741a31175abf5b6ca01c066da8a8db6e63da73b46bb524e293 SHA512 52d71984972c6888ade01fcc635d33a60c024424b82ac9319554f548438f8a4e2f32a8b7d3047ed86654c8ef67e3b6eac99728f9409b60cdffe7e842fd8fe16c
diff --git a/www-misc/urlwatch/urlwatch-2.14.ebuild b/www-misc/urlwatch/urlwatch-2.14.ebuild
new file mode 100644
index 000000000000..6dce261a7b8a
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-2.14.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="https://thp.io/2008/urlwatch/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/minidb[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+python_test() {
+ nosetests -v test || die "tests failed with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version dev-python/chump; then
+ elog "Install 'dev-python/chump' to enable Pushover" \
+ "notifications support"
+ fi
+ if ! has_version dev-python/pushbullet-py; then
+ elog "Install 'dev-python/pushbullet-py' to enable" \
+ "Pushbullet notifications support"
+ fi
+ elog "HTML parsing can be improved by installing one of the following packages"
+ elog "and changing the html2text subfilter parameter:"
+ elog "dev-python/beautifulsoup:4"
+ elog "app-text/html2text"
+ elog "dev-python/html2text"
+ elog "www-client/lynx"
+ fi
+}