summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-01-10 17:14:51 -0500
committerMike Gilbert <floppym@gentoo.org>2019-01-10 17:14:51 -0500
commitc5d8d8ce6d8b37f4b4fd19cfd9cd005ed2976415 (patch)
treec83ca783dd56745f8bc3f92ab20e51cb47a62c58 /www-plugins/chrome-binary-plugins/chrome-binary-plugins-72.0.3626.53_beta.ebuild
parentwww-client/google-chrome-unstable: automated update (73.0.3664.3) (diff)
downloadgentoo-c5d8d8ce6d8b37f4b4fd19cfd9cd005ed2976415.tar.gz
gentoo-c5d8d8ce6d8b37f4b4fd19cfd9cd005ed2976415.tar.bz2
gentoo-c5d8d8ce6d8b37f4b4fd19cfd9cd005ed2976415.zip
www-plugins/chrome-binary-plugins: automated update
Package-Manager: Portage-2.3.54_p2, Repoman-2.3.12_p42 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'www-plugins/chrome-binary-plugins/chrome-binary-plugins-72.0.3626.53_beta.ebuild')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-72.0.3626.53_beta.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-72.0.3626.53_beta.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-72.0.3626.53_beta.ebuild
new file mode 100644
index 000000000000..786fa7513bc5
--- /dev/null
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-72.0.3626.53_beta.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib unpacker
+
+DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
+HOMEPAGE="https://www.google.com/chrome"
+
+case ${PV} in
+ *_alpha*)
+ SLOT="unstable"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_alpha}-1
+ ;;
+ *_beta*)
+ SLOT="beta"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_beta}-1
+ ;;
+ *)
+ SLOT="stable"
+ CHROMEDIR="opt/google/chrome"
+ MY_PV=${PV}-1
+ ;;
+esac
+
+MY_PN="google-chrome-${SLOT}"
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
+KEYWORDS="-* ~amd64"
+
+LICENSE="google-chrome"
+IUSE="+widevine"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ widevine? (
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ !<www-client/chromium-57[widevine(-)]
+ )
+"
+
+for x in 0 beta stable unstable; do
+ if [[ ${SLOT} != ${x} ]]; then
+ RDEPEND+=" !${CATEGORY}/${PN}:${x}"
+ fi
+done
+
+S="${WORKDIR}/${CHROMEDIR}"
+QA_PREBUILT="*"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/chromium
+ if use widevine; then
+ doins libwidevinecdm.so
+ dosym ../chromium/libwidevinecdm.so /usr/$(get_libdir)/chromium-browser/libwidevinecdm.so
+ fi
+}