summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-03-23 11:31:45 -0400
committerMike Gilbert <floppym@gentoo.org>2019-03-23 11:32:03 -0400
commit5d0d65f57205d83b79191db353051c62874817ae (patch)
tree80235afd5fecd16bc9611cc737484db9da884d6e /www-plugins/chrome-binary-plugins/chrome-binary-plugins-74.0.3729.28_beta.ebuild
parentwww-client/google-chrome-unstable: automated update (74.0.3729.28) (diff)
downloadgentoo-5d0d65f57205d83b79191db353051c62874817ae.tar.gz
gentoo-5d0d65f57205d83b79191db353051c62874817ae.tar.bz2
gentoo-5d0d65f57205d83b79191db353051c62874817ae.zip
www-plugins/chrome-binary-plugins: automated update
Package-Manager: Portage-2.3.62_p4, Repoman-2.3.12_p87 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'www-plugins/chrome-binary-plugins/chrome-binary-plugins-74.0.3729.28_beta.ebuild')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-74.0.3729.28_beta.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-74.0.3729.28_beta.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-74.0.3729.28_beta.ebuild
new file mode 100644
index 000000000000..3fd84e77d226
--- /dev/null
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-74.0.3729.28_beta.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2012-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib unpacker
+
+DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
+HOMEPAGE="https://www.google.com/chrome"
+
+case ${PV} in
+ *_alpha*)
+ SLOT="unstable"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_alpha}-1
+ ;;
+ *_beta*)
+ SLOT="beta"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_beta}-1
+ ;;
+ *)
+ SLOT="stable"
+ CHROMEDIR="opt/google/chrome"
+ MY_PV=${PV}-1
+ ;;
+esac
+
+MY_PN="google-chrome-${SLOT}"
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
+KEYWORDS="-* ~amd64"
+
+LICENSE="google-chrome"
+IUSE="+widevine"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ widevine? (
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ !<www-client/chromium-57[widevine(-)]
+ )
+"
+
+for x in 0 beta stable unstable; do
+ if [[ ${SLOT} != ${x} ]]; then
+ RDEPEND+=" !${CATEGORY}/${PN}:${x}"
+ fi
+done
+
+S="${WORKDIR}/${CHROMEDIR}"
+QA_PREBUILT="*"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/chromium
+ if use widevine; then
+ doins libwidevinecdm.so
+ dosym ../chromium/libwidevinecdm.so /usr/$(get_libdir)/chromium-browser/libwidevinecdm.so
+ fi
+}