summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-01-06 12:24:45 -0500
committerMike Gilbert <floppym@gentoo.org>2020-01-06 12:24:45 -0500
commitb5dd81ae22d2d5ec61e74f1dd3fc457ca77f71cf (patch)
tree7e87ccb144da24a36fb7984d2aa27bc0e608e5c0 /www-plugins/chrome-binary-plugins/chrome-binary-plugins-81.0.4000.3_alpha.ebuild
parentwww-client/google-chrome-unstable: automated update (81.0.4000.3) (diff)
downloadgentoo-b5dd81ae22d2d5ec61e74f1dd3fc457ca77f71cf.tar.gz
gentoo-b5dd81ae22d2d5ec61e74f1dd3fc457ca77f71cf.tar.bz2
gentoo-b5dd81ae22d2d5ec61e74f1dd3fc457ca77f71cf.zip
www-plugins/chrome-binary-plugins: automated update
Package-Manager: Portage-2.3.84_p2, Repoman-2.3.20_p24 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'www-plugins/chrome-binary-plugins/chrome-binary-plugins-81.0.4000.3_alpha.ebuild')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-81.0.4000.3_alpha.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-81.0.4000.3_alpha.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-81.0.4000.3_alpha.ebuild
new file mode 100644
index 000000000000..50f2de431d29
--- /dev/null
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-81.0.4000.3_alpha.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2012-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib unpacker
+
+DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
+HOMEPAGE="https://www.google.com/chrome"
+
+case ${PV} in
+ *_alpha*)
+ SLOT="unstable"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_alpha}-1
+ ;;
+ *_beta*)
+ SLOT="beta"
+ CHROMEDIR="opt/google/chrome-${SLOT}"
+ MY_PV=${PV%_beta}-1
+ ;;
+ *)
+ SLOT="stable"
+ CHROMEDIR="opt/google/chrome"
+ MY_PV=${PV}-1
+ ;;
+esac
+
+MY_PN="google-chrome-${SLOT}"
+MY_P="${MY_PN}_${MY_PV}"
+
+SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
+KEYWORDS="-* ~amd64"
+
+LICENSE="google-chrome"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ !<www-client/chromium-57[widevine(-)]
+"
+
+for x in 0 beta stable unstable; do
+ if [[ ${SLOT} != ${x} ]]; then
+ RDEPEND+=" !${CATEGORY}/${PN}:${x}"
+ fi
+done
+
+S="${WORKDIR}/${CHROMEDIR}"
+QA_PREBUILT="*"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
+}
+
+src_install() {
+ insinto "/usr/$(get_libdir)/chromium-browser"
+ doins -r WidevineCdm
+}