summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-01-31 19:03:26 -0500
committerMike Gilbert <floppym@gentoo.org>2016-01-31 19:03:54 -0500
commit8242471835b0e8f12fc0c1cb223fb30c82fa37b2 (patch)
tree63b741fc8a2d84ac274ed7c4c7dfc8538a3a17c1 /www-plugins
parentwww-plugins/chrome-binary-plugins: Bump, drops x86 support (diff)
downloadgentoo-8242471835b0e8f12fc0c1cb223fb30c82fa37b2.tar.gz
gentoo-8242471835b0e8f12fc0c1cb223fb30c82fa37b2.tar.bz2
gentoo-8242471835b0e8f12fc0c1cb223fb30c82fa37b2.zip
www-plugins/chrome-binary-plugins: Drop the live ebuild
Package-Manager: portage-2.2.27_p57
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-9999.ebuild99
1 files changed, 0 insertions, 99 deletions
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9999.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9999.ebuild
deleted file mode 100644
index 0d9e442ee50b..000000000000
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-9999.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit multilib unpacker
-
-DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
-HOMEPAGE="https://www.google.com/chrome"
-
-case ${PV} in
- *_alpha*|9999*)
- SLOT="unstable"
- CHROMEDIR="opt/google/chrome-${SLOT}"
- MY_PV=${PV/_alpha/-}
- ;;
- *_beta*)
- SLOT="beta"
- CHROMEDIR="opt/google/chrome-${SLOT}"
- MY_PV=${PV/_beta/-}
- ;;
- *_p*)
- SLOT="stable"
- CHROMEDIR="opt/google/chrome"
- MY_PV=${PV/_p/-}
- ;;
- *)
- die "Invalid value for \${PV}: ${PV}"
- ;;
-esac
-
-MY_PN="google-chrome-${SLOT}"
-MY_P="${MY_PN}_${MY_PV}"
-
-if [[ ${PV} != 9999* ]]; then
-SRC_URI="
- amd64? (
- https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb
- )
- x86? (
- https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_i386.deb
- )
-"
-KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="google-chrome"
-IUSE="+flash +widevine"
-RESTRICT="bindist mirror strip"
-
-for x in 0 beta stable unstable; do
- if [[ ${SLOT} != ${x} ]]; then
- RDEPEND+=" !${CATEGORY}/${PN}:${x}"
- fi
-done
-
-S="${WORKDIR}/${CHROMEDIR}"
-QA_PREBUILT="*"
-
-pkg_nofetch() {
- eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
-}
-
-if [[ ${PV} == 9999* ]]; then
-src_unpack() {
- local base="https://dl.google.com/linux/direct"
- local debarch=${ARCH/x86/i386}
- wget -O google-chrome.deb "${base}/google-chrome-${SLOT}_current_${debarch}.deb" || die
- unpack_deb ./google-chrome.deb
-}
-fi
-
-src_install() {
- local version flapper
-
- insinto /usr/$(get_libdir)/chromium-browser/
-
- if use widevine; then
- doins libwidevinecdm.so
- strings ./chrome | grep -C 1 " (version:" | tail -1 > widevine.version
- doins widevine.version
- fi
-
- if use flash; then
- doins -r PepperFlash
-
- # Since this is a live ebuild, we're forced to, unfortuantely,
- # dynamically construct the command line args for Chromium.
- version=$(sed -n 's/.*"version": "\(.*\)",.*/\1/p' PepperFlash/manifest.json)
- flapper="${ROOT}usr/$(get_libdir)/chromium-browser/PepperFlash/libpepflashplayer.so"
- echo -n "CHROMIUM_FLAGS=\"\${CHROMIUM_FLAGS} " > pepper-flash
- echo -n "--ppapi-flash-path=$flapper " >> pepper-flash
- echo "--ppapi-flash-version=$version\"" >> pepper-flash
-
- insinto /etc/chromium/
- doins pepper-flash
- fi
-}