summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2019-05-30 19:28:01 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-06-07 21:15:11 +0200
commit88293edf8093014e88358e611ef2ca6ca1318ff9 (patch)
tree060b3aca0496dbd688528780e2ac554ca8dcdba3 /www-servers/nginx-unit
parentdev-python/pymilter: remove proxy-maint project (diff)
downloadgentoo-88293edf8093014e88358e611ef2ca6ca1318ff9.tar.gz
gentoo-88293edf8093014e88358e611ef2ca6ca1318ff9.tar.bz2
gentoo-88293edf8093014e88358e611ef2ca6ca1318ff9.zip
www-servers/nginx-unit: upstream release 1.9.0
Changelog available at https://unit.nginx.org/CHANGES.txt Signed-off-by: Ralph Seichter <gentoo@seichter.de> Package-Manager: Portage-2.3.66, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/12136 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-servers/nginx-unit')
-rw-r--r--www-servers/nginx-unit/Manifest1
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.9.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/www-servers/nginx-unit/Manifest b/www-servers/nginx-unit/Manifest
index b25404bae3df..2226de44e195 100644
--- a/www-servers/nginx-unit/Manifest
+++ b/www-servers/nginx-unit/Manifest
@@ -4,3 +4,4 @@ DIST nginx-unit-1.6.tar.gz 439244 BLAKE2B 38e5580eed131b92f7fb73f389bd1dcc713a09
DIST nginx-unit-1.7.1.tar.gz 445348 BLAKE2B ce71948575c1d4c8cd6a918625525a77094c7b9bee335283a131bdf72e863f4a645761074642bf4150b1aeaf61c5d95302e0e2f0547483fc76b7ab3784aeb1d0 SHA512 08073aced61aff6cb9891128d4e5eb96096f113cfbff3418976fb7f896762e6abe2f08202935cf464f7b547daade89e071c616496969447a5aa35e77004d4ffa
DIST nginx-unit-1.7.tar.gz 445144 BLAKE2B 99f985768551bb3d12fa09751c3bad9ffbfd0bb9768914a439bf420e438b468f5baa909866c6f7518c6ab17335ddcb69f312207f8f0a8b25dc28ddb2c5bb75d7 SHA512 68156a8dd69401895d40f2c23d7889f3998f52dd7bfd5c3efb7894e5267aef0075868db857fbbbc34f85ed9d56b9ea4fa7a19f662eb91f68284eb99a55f0380b
DIST nginx-unit-1.8.0.tar.gz 511226 BLAKE2B e396b27954840a5f1ad3a4cd9501a5e5fe769a754c51043da784a2c4596e6acc33089f495bf412a0db086e5c715a51292c7dece004a6512564421a431b6c339e SHA512 1d0ad05343ff70aff4c6e221a36c20df95fa2e2262ae5c69963a9bcb9ef883151e8a2fa9fef29f43ac5489aa5cbb3e9dfd10cf5e7f6d7a98742b490ebf3a0413
+DIST nginx-unit-1.9.0.tar.gz 522420 BLAKE2B 8fabd8a43c8e5b07a8d9db41bb1d9790a6d434a20b762649557bc4e715a00b663416cd9556c9e5fc1894487172c1549de4d5511259876ea6bcd306e258e0ff5f SHA512 25beda88e3e92cace7acfee45a640c351f4e15f20f2aa0f047c3ba61351c6119f270754186f39ab3f1fcc16b1bef9009da4f507d5cdf511538825f2a4c879d62
diff --git a/www-servers/nginx-unit/nginx-unit-1.9.0.ebuild b/www-servers/nginx-unit/nginx-unit-1.9.0.ebuild
new file mode 100644
index 000000000000..3b4b5a06037d
--- /dev/null
+++ b/www-servers/nginx-unit/nginx-unit-1.9.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python2_7 python3_{5,6,7})
+
+inherit python-single-r1
+
+MY_P="unit-${PV}"
+DESCRIPTION="A dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php5-6 php7-1 php7-2 php7-3"
+IUSE="${MY_USE} ${MY_USE_PHP}"
+REQUIRED_USE="|| ( ${IUSE} ) python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+ php5-6? ( dev-lang/php:5.6[embed] )
+ php7-1? ( dev-lang/php:7.1[embed] )
+ php7-2? ( dev-lang/php:7.2[embed] )
+ php7-3? ( dev-lang/php:7.3[embed] )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby:= )"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ ./configure \
+ --control=unix:/run/${PN}.sock \
+ --ld-opt="${LDFLAGS}" \
+ --log=/var/log/${PN} \
+ --modules=$(get_libdir)/${PN} \
+ --pid=/run/${PN}.pid \
+ --prefix=/usr \
+ --state=/var/lib/${PN} || die "Core configuration failed"
+ for flag in ${MY_USE} ; do
+ if use ${flag} ; then
+ ./configure ${flag} || die "Module configuration failed: ${flag}"
+ fi
+ done
+ for flag in ${MY_USE_PHP} ; do
+ if use ${flag} ; then
+ local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+ ./configure php \
+ --module=${flag} \
+ --config=${php_slot}/bin/php-config \
+ --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+ fi
+ done
+}
+
+src_install() {
+ default
+ diropts -m 0770
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}