summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-26 12:52:14 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-26 12:55:43 +0200
commit150e69f513bfb2640e503cbbf61bd4dec8bc8fc9 (patch)
tree71345c536d246452b80800b68bfb671ad0afd513 /www-servers/pshs
parentwww-servers/pshs: -9999 no longer requires libnetlink (diff)
downloadgentoo-150e69f513bfb2640e503cbbf61bd4dec8bc8fc9.tar.gz
gentoo-150e69f513bfb2640e503cbbf61bd4dec8bc8fc9.tar.bz2
gentoo-150e69f513bfb2640e503cbbf61bd4dec8bc8fc9.zip
www-servers/pshs: Bump to 0.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-servers/pshs')
-rw-r--r--www-servers/pshs/Manifest1
-rw-r--r--www-servers/pshs/pshs-0.3.5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/www-servers/pshs/Manifest b/www-servers/pshs/Manifest
index ac8a72f797e7..36125932ed17 100644
--- a/www-servers/pshs/Manifest
+++ b/www-servers/pshs/Manifest
@@ -1 +1,2 @@
DIST pshs-0.3.4.tar.bz2 81435 BLAKE2B e5a72c02efbaa95f0069d2533ce4434da88a5eaf33b7025b5d83bd0679631d6ee0b1faf31a5f3b0ed3bf2e23d4500bf6f473d997cabf99d8b769f4a2c662d32f SHA512 d264b46ad54286d5c4fac601e3353c1029af75ad59f28fea5a2970dc7e9b00327a08dfdd82141c76656f07047cfce1fa35b485b2f69f0728bcf74c835def917d
+DIST pshs-0.3.5.tar.bz2 79871 BLAKE2B 07322ce82d80ecc0db166672d1694902a3ae743fd5d43d79261fab66a2f08e58f990d3c5a47dd39c9d041f195cacf31d5db3546336ccc3d961709d17712adf53 SHA512 5cb0cd8950f708f0c4d7b9281e2863440c579557c285fdfda1082eebf849bfb7cd25965de05c7f7b96527eed94b95c635f8cd2d397ebfd4af12195f70b3c5648
diff --git a/www-servers/pshs/pshs-0.3.5.ebuild b/www-servers/pshs/pshs-0.3.5.ebuild
new file mode 100644
index 000000000000..6b3e64295963
--- /dev/null
+++ b/www-servers/pshs/pshs-0.3.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Pretty small HTTP server -- a command-line tool to share files"
+HOMEPAGE="https://github.com/mgorny/pshs/"
+SRC_URI="https://github.com/mgorny/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl +magic qrcode ssl upnp"
+
+RDEPEND=">=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ ssl? ( >=dev-libs/libevent-2.1:0=[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ upnp? ( net-libs/miniupnpc:0= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf=(
+ $(use_enable magic libmagic)
+ $(use_enable qrcode qrencode)
+ $(use_enable ssl)
+ $(use_enable upnp)
+ )
+
+ econf "${myconf[@]}"
+}