summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-06-26 06:52:52 +0200
committerHans de Graaff <graaff@gentoo.org>2019-06-26 06:52:52 +0200
commit0beaf449f8377687dd2a7fa42b868c8e455e8de0 (patch)
tree5ed0343e960293c17444505bcf60f9046c8afe5b /www-servers
parentdev-ruby/public_suffix: add 4.0.0 (diff)
downloadgentoo-0beaf449f8377687dd2a7fa42b868c8e455e8de0.tar.gz
gentoo-0beaf449f8377687dd2a7fa42b868c8e455e8de0.tar.bz2
gentoo-0beaf449f8377687dd2a7fa42b868c8e455e8de0.zip
www-servers/puma: add 4.0.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/puma/Manifest1
-rw-r--r--www-servers/puma/puma-4.0.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/www-servers/puma/Manifest b/www-servers/puma/Manifest
index e3204142cb6..532c474871b 100644
--- a/www-servers/puma/Manifest
+++ b/www-servers/puma/Manifest
@@ -1 +1,2 @@
DIST puma-3.12.1.tar.gz 217543 BLAKE2B 6427c48d17ead515a17fd53ba05baba0ca27b9a3c6b26257e83b21ce099d7ff36666dfe1f1a964d23addd666c5aa83c46e6795ad2e22236de7136e25be689ff5 SHA512 70784ed89403e96d1bdb68f3ee0a5446d98a6f8a1af5ddf369d837e2ae3320118c29c9c33e7a9db7a76b1a80aef66a9b6426140c492721984de50e7cc5fc8300
+DIST puma-4.0.0.tar.gz 224071 BLAKE2B ff8adaf78a6534739e7a93d50ee4a82548d89698f4f9007e38ae7fd92bf97ce19e515a2f31556884655d30bb2f0d8395262a2c32125543728ba3c5d1f14fdebd SHA512 5393a254e213ef4e9378ce1ffd05b5a0db54a356f1293dabca04cd2281673d28dfa619750b618b415f7673c47f6edbec5c1a7332e962901b17fb434b60156373
diff --git a/www-servers/puma/puma-4.0.0.ebuild b/www-servers/puma/puma-4.0.0.ebuild
new file mode 100644
index 00000000000..cc803276711
--- /dev/null
+++ b/www-servers/puma/puma-4.0.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
+HOMEPAGE="https://puma.io/"
+SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
+RDEPEND+=" dev-libs/openssl:0"
+
+ruby_add_bdepend "virtual/ruby-ssl
+ test? ( dev-ruby/rack >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' test/helper.rb || die
+
+ # Avoid test failing inconsistently
+ sed -i -e '/phased_restart_via_pumactl/,/^ end/ s:^:#:' test/test_integration.rb || die
+
+ # Avoid test that trigger a bug in ruby very easily and lead to
+ # failure. This affects all current puma versions in combination
+ # with the latest ruby versions, so we add this new version anyway
+ # while allowing these tests to fail.
+ # https://github.com/puma/puma/pull/1345
+ rm -f test/test_puma_server_ssl.rb || die
+
+ # Use correct ruby version
+ sed -i -e 's/ruby -rrubygems/#{Gem.ruby} -rrubygems/' test/shell/t{1,3}.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -rubygems:'${RUBY}' -rubygems:' \
+ -e 's/localhost/127.0.0.1/' test/shell/* || die
+ sed -i -e '1ilog_requests' test/shell/t{1,2}_conf.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/puma_http11 extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/puma_http11
+ cp ext/puma_http11/puma_http11$(get_modname) lib/puma/ || die
+}
+
+each_ruby_test() {
+ einfo "Running test suite"
+ ${RUBY} -Ilib:.:test -e "gem 'minitest', '~>5.9'; gem 'test-unit', '~>3.0'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{|f| require f}" || die
+
+ einfo "Running integration tests"
+ pushd test/shell
+ #sh run.sh || die
+ popd
+}