summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-02-18 02:51:27 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-02-18 02:51:27 -0500
commit395a9f32631e797fedb0c27ac38bc12b8877adb3 (patch)
tree0e6178e297474aceffd6af0903d3dfa66f2959d6 /www-servers
parentnet-misc/electrum: version bump to 3.0.6 (diff)
downloadgentoo-395a9f32631e797fedb0c27ac38bc12b8877adb3.tar.gz
gentoo-395a9f32631e797fedb0c27ac38bc12b8877adb3.tar.bz2
gentoo-395a9f32631e797fedb0c27ac38bc12b8877adb3.zip
www-servers/varnish: version bump to 5.2.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/varnish/Manifest1
-rw-r--r--www-servers/varnish/varnish-5.2.0.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/www-servers/varnish/Manifest b/www-servers/varnish/Manifest
index 8b4f1470a2e5..3d62d48784b6 100644
--- a/www-servers/varnish/Manifest
+++ b/www-servers/varnish/Manifest
@@ -1,3 +1,4 @@
DIST varnish-4.0.5.tgz 1947888 BLAKE2B d921dc6f2abae7b0bd1816470fd41f8555c02a02607b49bf8f36a0b778dd926ea0f5e8cf8a60aaceb097bd4193e22fc7d718c1f13a4f8502b57b797277c66f5a SHA512 a08259f6f9c6fffa188b26c1f8c630de5e6d2f6d52f6efa9d5d8239cdd8721c53e2be3379f8100efb537e74416eadd6c865f4cc687db1c5a9f757bb3f73abeda
DIST varnish-4.1.8.tgz 2254772 BLAKE2B acadf4079d58bb8f0dc5e24713aba7f2786ca6f06a683465b1564bacd986e209d858f9a3100cfb7586fa5d17f7e5f4d8425ece10c609bb3412d3adafa6ad0d05 SHA512 c642359118d87e8713d2ccf817da317a454a0f9ae6f7a07da1d10b5076aa7e5d7dcc203ef71ae19d56b7592db0c66b4ca96cb43d5fa0e6aa588d1dc8e03e026e
DIST varnish-5.1.3.tgz 2643223 BLAKE2B 85bae87785da1284d7d916b8948a0984eea9cf07e96012255435ba04c28e8078e5dad893946bbc12da6cbe9326699458f0e3af6be55cb5e7bba4e622724ddac2 SHA512 a10c317dc38ddff139ca8153f6388955df449c3abeb4d4f069b632ba2b32064a2827ab05fa8515994b251a68507fc3a7bf4e08eacc991fc03283ab234b9efd0a
+DIST varnish-5.2.0.tgz 2828867 BLAKE2B 42bf09df723e768e4223f09dc89fffb08b2341a6bb8975c1a6bd719d36996ea38e38a6693fa26f926c3fece845c01df123f64807e4b5477568000779eda2ffcc SHA512 a962846492356efedaa9b2e5076b9f2423a88ed33dfd11fdeb7690d5622c3d73c782a48cbafdf919b7fca7d37b5b9f4f1243ac925e010ccbc086ae12e87c5627
diff --git a/www-servers/varnish/varnish-5.2.0.ebuild b/www-servers/varnish/varnish-5.2.0.ebuild
new file mode 100644
index 000000000000..13a770025846
--- /dev/null
+++ b/www-servers/varnish/varnish-5.2.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit user autotools systemd python-r1
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="http://www.varnish-cache.org/"
+SRC_URI="http://varnish-cache.org/_downloads/${P}.tgz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="jemalloc jit static-libs"
+
+CDEPEND="
+ sys-libs/readline:0=
+ dev-libs/libpcre[jit?]
+ jemalloc? ( dev-libs/jemalloc )
+ sys-libs/ncurses:0="
+
+#varnish compiles stuff at run time
+RDEPEND="
+ ${PYTHON_DEPS}
+ ${CDEPEND}
+ sys-devel/gcc"
+
+DEPEND="
+ ${CDEPEND}
+ dev-python/docutils
+ virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test" #315725
+
+pkg_setup() {
+ ebegin "Creating varnish user and group"
+ enewgroup varnish
+ enewuser varnish -1 -1 /var/lib/varnish varnish
+ eend $?
+}
+
+src_prepare() {
+ # Remove -Werror bug #528354
+ sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac
+
+ # Upstream doesn't put varnish.m4 in the m4/ directory
+ # We link because the Makefiles look for the file in
+ # the original location
+ ln -sf ../varnish.m4 m4/varnish.m4
+
+ eapply_user
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable jit pcre-jit ) \
+ $(use_with jemalloc)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
+
+ newinitd "${FILESDIR}"/varnishlog.initd varnishlog
+ newconfd "${FILESDIR}"/varnishlog.confd varnishlog
+
+ newinitd "${FILESDIR}"/varnishncsa.initd varnishncsa
+ newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
+
+ newinitd "${FILESDIR}"/varnishd.initd-r4 varnishd
+ newconfd "${FILESDIR}"/varnishd.confd-r4 varnishd
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
+
+ diropts -m750
+
+ dodir /var/log/varnish/
+
+ systemd_dounit "${FILESDIR}/${PN}d.service"
+
+ insinto /etc/varnish/
+ doins lib/libvmod_std/vmod.vcc
+ doins etc/example.vcl
+
+ dodoc README.rst
+ dodoc doc/changes.rst
+
+ fowners root:varnish /etc/varnish/
+ fowners varnish:varnish /var/lib/varnish/
+ fperms 0750 /var/lib/varnish/ /etc/varnish/
+}