summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2020-05-30 19:45:14 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-12 16:44:42 +0200
commit9c0cda00919769cc6b1bff6d57ba6f348948ef7d (patch)
tree2738ba8aad8506a1602d84444185d315f2763c24 /www-servers
parentwww-apps/kibana-bin: drop old (diff)
downloadgentoo-9c0cda00919769cc6b1bff6d57ba6f348948ef7d.tar.gz
gentoo-9c0cda00919769cc6b1bff6d57ba6f348948ef7d.tar.bz2
gentoo-9c0cda00919769cc6b1bff6d57ba6f348948ef7d.zip
www-servers/nginx-unit: Bump to version 1.18.0
See http://unit.nginx.org/CHANGES.txt for the upstream change log. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Closes: https://github.com/gentoo/gentoo/pull/16018 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx-unit/Manifest1
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.18.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/www-servers/nginx-unit/Manifest b/www-servers/nginx-unit/Manifest
index fdb40a579efd..fe905a146f0a 100644
--- a/www-servers/nginx-unit/Manifest
+++ b/www-servers/nginx-unit/Manifest
@@ -1 +1,2 @@
DIST nginx-unit-1.17.0.tar.gz 726928 BLAKE2B d171f2f818302cb0f491ccc3ca93596ee52817647cf1f2f176ebed075cb1dd5772f133d9e925075fe72d826a63b4c4debddace8784612196ebe6b6655d70571b SHA512 4175fc6dd84ad8a3bbdc117d3ce0c7a11c708a7a204ade0bb40f5606f6923e351bb1a8f1f8394c09cdf12fdc20bc927920412dc4b41d3141f76482db047c4bed
+DIST nginx-unit-1.18.0.tar.gz 742273 BLAKE2B d856aadb07286acb944a7bd486fc8c548db0412f8e4e2bec0382aa719d743ee22208c20ccf50466e3d592e29690abfacbfd6d4c44b1369bdc5a61ca2765bd3d2 SHA512 2beac69caeb09278a6c2cdafe20a8040e589f9ad6e302c896cd396ae7d576f563dd6a480f815b4a26d22e15592b5abcd927a8ba436517bd9b9bbb78bff3176ff
diff --git a/www-servers/nginx-unit/nginx-unit-1.18.0.ebuild b/www-servers/nginx-unit/nginx-unit-1.18.0.ebuild
new file mode 100644
index 000000000000..ac0c6c8fc956
--- /dev/null
+++ b/www-servers/nginx-unit/nginx-unit-1.18.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6,7,8})
+
+inherit flag-o-matic python-single-r1 toolchain-funcs
+
+MY_P="unit-${PV}"
+DESCRIPTION="Dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php7-2 php7-3 php7-4"
+IUSE="${MY_USE} ${MY_USE_PHP} ssl"
+REQUIRED_USE="|| ( ${IUSE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+ php7-2? ( dev-lang/php:7.2[embed] )
+ php7-3? ( dev-lang/php:7.3[embed] )
+ php7-4? ( dev-lang/php:7.4[embed] )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby:* )
+ ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply_user
+ sed -i '/^CFLAGS/d' auto/make || die
+}
+
+src_configure() {
+ local opt=(
+ --control=unix:/run/${PN}.sock
+ --log=/var/log/${PN}
+ --modules=$(get_libdir)/${PN}
+ --pid=/run/${PN}.pid
+ --prefix=/usr
+ --state=/var/lib/${PN}
+ )
+ use ssl && opt+=( --openssl )
+ export AR="$(tc-getAR)"
+ export CC="$(tc-getCC)"
+ ./configure ${opt[@]} --ld-opt="${LDFLAGS}" || die "Core configuration failed"
+ # Modules require position-independent code
+ append-cflags $(test-flags-CC -fPIC)
+ for flag in ${MY_USE} ; do
+ if use ${flag} ; then
+ ./configure ${flag} || die "Module configuration failed: ${flag}"
+ fi
+ done
+ for flag in ${MY_USE_PHP} ; do
+ if use ${flag} ; then
+ local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+ ./configure php \
+ --module=${flag} \
+ --config=${php_slot}/bin/php-config \
+ --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+ fi
+ done
+}
+
+src_install() {
+ default
+ diropts -m 0770
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}