summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-apps/xsm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-apps/xsm')
-rw-r--r--x11-apps/xsm/Manifest1
-rw-r--r--x11-apps/xsm/metadata.xml8
-rw-r--r--x11-apps/xsm/xsm-1.0.3.ebuild33
3 files changed, 42 insertions, 0 deletions
diff --git a/x11-apps/xsm/Manifest b/x11-apps/xsm/Manifest
new file mode 100644
index 000000000000..7ede35aea052
--- /dev/null
+++ b/x11-apps/xsm/Manifest
@@ -0,0 +1 @@
+DIST xsm-1.0.3.tar.bz2 161012 SHA256 ad9dee2847a683841f73518a83014b0accae60e9eff7e96752a0dbc412867b4a SHA512 930a12272011ddd7c60e62b32b485c383292163f8aed6086c756f71cece62d0c316d89a6056751818b3b0ee26f68cca6e0fc914cd58d9b20da0a3b7ccf2145f0 WHIRLPOOL bb8a30a849c3570c91a69b5490509919fe19e9f986a018e8ea7b71b36aa986c2770eba4206b8d17918f3a3f199dc34c105e57aaa23716d897f81bb5f8682c2b6
diff --git a/x11-apps/xsm/metadata.xml b/x11-apps/xsm/metadata.xml
new file mode 100644
index 000000000000..264927988512
--- /dev/null
+++ b/x11-apps/xsm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+<use>
+ <flag name="rsh">This allows the use of rsh (remote shell) and rcp (remote copy).</flag>
+</use>
+</pkgmetadata>
diff --git a/x11-apps/xsm/xsm-1.0.3.ebuild b/x11-apps/xsm/xsm-1.0.3.ebuild
new file mode 100644
index 000000000000..fdd292a8c4a2
--- /dev/null
+++ b/x11-apps/xsm/xsm-1.0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="X Session Manager"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="rsh"
+RDEPEND="x11-libs/libXaw
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM
+ rsh? ( net-misc/netkit-rsh )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ # (#158056) /usr/$(get_libdir)/X11/xsm could be a symlink
+ local XSMPATH="${EROOT}usr/$(get_libdir)/X11/xsm"
+ if [[ -L ${XSMPATH} ]]; then
+ einfo "Removing symlink ${XSMPATH}"
+ rm -f ${XSMPATH} || die "failed to remove symlink ${XSMPATH}"
+ fi
+ xorg-2_pkg_setup
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS="$(use_with rsh rsh /usr/bin/rsh)"
+ xorg-2_src_configure
+}