summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-02-24 18:44:36 -0500
committerMatt Turner <mattst88@gentoo.org>2021-02-24 19:02:23 -0500
commit6f39261cc89b0374ea4fed0c44b8888bda101a05 (patch)
treec2d002dca156580369277966bf3f811c01cfc452 /x11-base
parentx11-base/xorg-proto: Propagate ~riscv keywords (diff)
downloadgentoo-6f39261cc89b0374ea4fed0c44b8888bda101a05.tar.gz
gentoo-6f39261cc89b0374ea4fed0c44b8888bda101a05.tar.bz2
gentoo-6f39261cc89b0374ea4fed0c44b8888bda101a05.zip
x11-base/xorg-proto: Add IUSE=test
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-proto/xorg-proto-9999.ebuild25
1 files changed, 22 insertions, 3 deletions
diff --git a/x11-base/xorg-proto/xorg-proto-9999.ebuild b/x11-base/xorg-proto/xorg-proto-9999.ebuild
index c88ebbc8d77a..2c391aa1de4d 100644
--- a/x11-base/xorg-proto/xorg-proto-9999.ebuild
+++ b/x11-base/xorg-proto/xorg-proto-9999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
MY_PN="${PN/xorg-/xorg}"
MY_P="${MY_PN}-${PV}"
@@ -12,7 +13,7 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
-inherit ${GIT_ECLASS} meson
+inherit ${GIT_ECLASS} meson python-any-r1
DESCRIPTION="X.Org combined protocol headers"
HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
@@ -26,4 +27,22 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND=""
+
+python_check_deps() {
+ has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}