summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-05-27 17:00:08 -0700
committerMatt Turner <mattst88@gentoo.org>2018-05-27 17:00:19 -0700
commit7ad9a1b9c986031828510c1c86b40666b3ad5adc (patch)
treec1a64064a4982e1326247c99a81b72714a22a9ec /x11-drivers/xf86-input-wacom
parentx11-drivers/xf86-video-nouveau: Drop old versions (diff)
downloadgentoo-7ad9a1b9c986031828510c1c86b40666b3ad5adc.tar.gz
gentoo-7ad9a1b9c986031828510c1c86b40666b3ad5adc.tar.bz2
gentoo-7ad9a1b9c986031828510c1c86b40666b3ad5adc.zip
x11-drivers/xf86-input-wacom: Depend on virtual/libudev:=
Bug: https://bugs.gentoo.org/545906
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0-r1.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0-r1.ebuild
new file mode 100644
index 000000000000..4bcff4b9fed2
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://git.code.sf.net/p/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/libwacom
+ virtual/libudev:=
+ >=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${ED}"/usr/share/hal
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 3 17; then
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ else
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present HID_WACOM; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " HID support --->"
+ ewarn " Special HID drivers --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ fi
+
+}