summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-09-14 10:15:43 -0700
committerMatt Turner <mattst88@gentoo.org>2018-09-14 10:18:38 -0700
commit55a139e8b6c7cc7ed06e287f0234dc171009f5a4 (patch)
tree05820feb39b3c70c2796f031b577c5855fe05d4e /x11-drivers/xf86-video-ati
parentx11-drivers/xf86-video-amdgpu: Version bump to 18.1.0 (diff)
downloadgentoo-55a139e8b6c7cc7ed06e287f0234dc171009f5a4.tar.gz
gentoo-55a139e8b6c7cc7ed06e287f0234dc171009f5a4.tar.bz2
gentoo-55a139e8b6c7cc7ed06e287f0234dc171009f5a4.zip
x11-drivers/xf86-video-ati: Version bump to 18.1.0
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/Manifest1
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-18.1.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-ati/Manifest b/x11-drivers/xf86-video-ati/Manifest
index 458ae7e7d93e..f18b564cd086 100644
--- a/x11-drivers/xf86-video-ati/Manifest
+++ b/x11-drivers/xf86-video-ati/Manifest
@@ -1 +1,2 @@
DIST xf86-video-ati-18.0.1.tar.bz2 881457 BLAKE2B d45ae191239d008261230804161545e971d5ba9b76642341dad5dfb03b52aa3580e2e41fb7f0484af8da5024da46ada2bca182c15ec13053d674e456fb6f0f4a SHA512 b468a78503a596bbf71a1b91b231ce1fa32908f619ff2dfe249352d046696a3641f2a9ff065e32545fff77100134b4b237591215e78ef885b6509d6b16112d14
+DIST xf86-video-ati-18.1.0.tar.bz2 891953 BLAKE2B 9092554c708b583f9b99a6788104a1e9420537fbbeaaaa6ae7e82be2a2299ad834365d00f8b146ce845afb5e2a08d3de3da591143eff63d4fb34c7040251f443 SHA512 7a58c9a6cb4876bd2ff37d837372b4e360e81fec7de6a6c7a48d70a5338d62745f734f5d4207f30aa368ff2d9ef44f5f1ef36afd73802a618998c16fe395ed53
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-18.1.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-18.1.0.ebuild
new file mode 100644
index 000000000000..3f5390aec7a0
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-18.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_DRI=always
+inherit linux-info xorg-2
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="ATI video driver"
+HOMEPAGE="https://www.x.org/wiki/ati/"
+
+IUSE="+glamor udev"
+
+RDEPEND=">=x11-libs/libdrm-2.4.78[video_cards_radeon]
+ >=x11-libs/libpciaccess-0.8.0
+ glamor? ( x11-base/xorg-server[glamor] )
+ udev? ( virtual/libudev:= )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ if kernel_is -ge 3 9; then
+ CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
+ else
+ CONFIG_CHECK="~DRM_RADEON_KMS ~!FB_RADEON"
+ fi
+ fi
+ check_extra_config
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable glamor)
+ $(use_enable udev)
+ )
+ xorg-2_src_configure
+}