summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-03-07 10:16:11 -0800
committerMatt Turner <mattst88@gentoo.org>2019-03-07 10:17:27 -0800
commit5f6fa62a21794dbcb40ff7d41e94486cd5ecabdf (patch)
treeb5dce1f17629f34850d1805267149d254c306f49 /x11-drivers/xf86-video-ati
parentx11-drivers/xf86-video-ati: EAPI 7 (diff)
downloadgentoo-5f6fa62a21794dbcb40ff7d41e94486cd5ecabdf.tar.gz
gentoo-5f6fa62a21794dbcb40ff7d41e94486cd5ecabdf.tar.bz2
gentoo-5f6fa62a21794dbcb40ff7d41e94486cd5ecabdf.zip
x11-drivers/xf86-video-ati: Version bump to 19.0.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/Manifest1
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-19.0.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-ati/Manifest b/x11-drivers/xf86-video-ati/Manifest
index 553d8dc498d3..9ac8f8ad37fc 100644
--- a/x11-drivers/xf86-video-ati/Manifest
+++ b/x11-drivers/xf86-video-ati/Manifest
@@ -1 +1,2 @@
DIST xf86-video-ati-18.1.0.tar.bz2 891953 BLAKE2B 9092554c708b583f9b99a6788104a1e9420537fbbeaaaa6ae7e82be2a2299ad834365d00f8b146ce845afb5e2a08d3de3da591143eff63d4fb34c7040251f443 SHA512 7a58c9a6cb4876bd2ff37d837372b4e360e81fec7de6a6c7a48d70a5338d62745f734f5d4207f30aa368ff2d9ef44f5f1ef36afd73802a618998c16fe395ed53
+DIST xf86-video-ati-19.0.0.tar.bz2 901467 BLAKE2B 727581b205dd02995a9da2114d5a300e06172b1ee0fb02ea273d2fcf97dbc8cffea6ea6f12d8c6ed5a4a185a972ee4f007309e7331ca17ec0d2658df76aa349c SHA512 0674c8befa926fd3b431ce80d90f2cd0de17314efe7fd3a5ed0d78018d6cd32625b514bf68436a47eb15e5ad4b50317f3c09fd687b77e69a067d1210ee459827
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-19.0.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-19.0.0.ebuild
new file mode 100644
index 000000000000..bcca1714ec2f
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-19.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DRI=always
+inherit linux-info xorg-3
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+DESCRIPTION="ATI video driver"
+HOMEPAGE="https://www.x.org/wiki/ati/"
+
+IUSE="+glamor udev"
+
+RDEPEND=">=x11-libs/libdrm-2.4.89[video_cards_radeon]
+ >=x11-libs/libpciaccess-0.8.0
+ glamor? ( x11-base/xorg-server[glamor] )
+ udev? ( virtual/libudev:= )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ if kernel_is -ge 3 9; then
+ CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
+ else
+ CONFIG_CHECK="~DRM_RADEON_KMS ~!FB_RADEON"
+ fi
+ fi
+ check_extra_config
+}
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable glamor)
+ $(use_enable udev)
+ )
+}