summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-drivers/xf86-video-qxl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-drivers/xf86-video-qxl')
-rw-r--r--x11-drivers/xf86-video-qxl/Manifest2
-rw-r--r--x11-drivers/xf86-video-qxl/metadata.xml8
-rw-r--r--x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.3.ebuild25
-rw-r--r--x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.4.ebuild25
4 files changed, 60 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-qxl/Manifest b/x11-drivers/xf86-video-qxl/Manifest
new file mode 100644
index 000000000000..0ba41f5003e2
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/Manifest
@@ -0,0 +1,2 @@
+DIST xf86-video-qxl-0.1.3.tar.bz2 479196 SHA256 75786637cbfe278de78d52baa5aab217dd29af1b8a1f8b12d0c3c2584b6bc88c SHA512 0826f72725f4220f8ed33f823412662eb3aa3c650987a04f1c82a26b1e85a06b949b2490cffc5357b2272a3c39f481475b92c8cf2ef2e9575cf1d9a1be702b6d WHIRLPOOL c7018dbc7ac3430d205620d8e114e99c2335468babde7f3ae1285020a8ce6b492375501b15cf4699db9ada8dd94c623ecfb59c89e034e116d50e56db4f5a0915
+DIST xf86-video-qxl-0.1.4.tar.bz2 487656 SHA256 e57ad22f0b1daf8979e722be0cc38d351bfcc2e41568edc566d2bade5a621105 SHA512 6ce518bb3ee9fce6066b492351c25a4a429edf7eff4ecbe9dc49fe5ee1f1d68586761624d2601f4bb6c4f4ddf7996f2fc8024707501b0de76ab6932bfe82c51d WHIRLPOOL 3dcce31b1cdfda33ca78e66b9c221b27e0073808f956e0c98460fb2979d8dedf84f45f4adbbed6114c26597e5e2bc1d6be4b46fce83d6afdef0be63d2d848549
diff --git a/x11-drivers/xf86-video-qxl/metadata.xml b/x11-drivers/xf86-video-qxl/metadata.xml
new file mode 100644
index 000000000000..7fd8b1eb5c3e
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+<use>
+<flag name="xspice">Build the xspice driver</flag>
+</use>
+</pkgmetadata>
diff --git a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.3.ebuild b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.3.ebuild
new file mode 100644
index 000000000000..e7327ad3981e
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xorg-2
+
+DESCRIPTION="QEMU QXL paravirt video driver"
+
+KEYWORDS="amd64 x86"
+IUSE="xspice"
+
+RDEPEND="xspice? ( app-emulation/spice )
+ x11-base/xorg-server[-minimal]
+ >=x11-libs/libdrm-2.4.46"
+DEPEND="${RDEPEND}
+ x11-proto/xf86dgaproto
+ >=app-emulation/spice-protocol-0.12.0"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable xspice)
+ )
+ xorg-2_src_configure
+}
diff --git a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.4.ebuild b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.4.ebuild
new file mode 100644
index 000000000000..e3f20c41a9e1
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xorg-2
+
+DESCRIPTION="QEMU QXL paravirt video driver"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="xspice"
+
+RDEPEND="xspice? ( app-emulation/spice )
+ x11-base/xorg-server[-minimal]
+ >=x11-libs/libdrm-2.4.46"
+DEPEND="${RDEPEND}
+ x11-proto/xf86dgaproto
+ >=app-emulation/spice-protocol-0.12.0"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable xspice)
+ )
+ xorg-2_src_configure
+}