summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-05-29 20:42:17 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-05-29 20:42:17 +0200
commit4fa608d54407c60f2d8d60f6cc059f04de8fa6cb (patch)
treebdd075c029f5eac37e94a36b89b90d91232f707f /x11-drivers
parentdev-lang/swi-prolog: remove old development versions (diff)
downloadgentoo-4fa608d54407c60f2d8d60f6cc059f04de8fa6cb.tar.gz
gentoo-4fa608d54407c60f2d8d60f6cc059f04de8fa6cb.tar.bz2
gentoo-4fa608d54407c60f2d8d60f6cc059f04de8fa6cb.zip
x11-drivers/xf86-input-wacom: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/Manifest1
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.33.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-wacom/Manifest b/x11-drivers/xf86-input-wacom/Manifest
index 83c6f0e4fe4b..fb5f6ddc60ef 100644
--- a/x11-drivers/xf86-input-wacom/Manifest
+++ b/x11-drivers/xf86-input-wacom/Manifest
@@ -3,3 +3,4 @@ DIST xf86-input-wacom-0.29.0.tar.bz2 589495 SHA256 88507e76f1eb98a20c4381806e03c
DIST xf86-input-wacom-0.30.0.tar.bz2 591648 SHA256 8ad4e479a4fc6d3c18e680958a8f42c3c87f15fdf8d2561810ca01a0a78841f5 SHA512 115e87715e736d77ad4e45e29287c855289cea5871983b7ad2e7e1e64954078de184d1b78157e958a0c9e7b949061b4c5599e2b11e87d5019a843bcaa34e0381 WHIRLPOOL 92f93b8694760c5dfbfb0182909e5b2ec3a8c197143962249c032f51483f3b194db12ad522cdfe8401b7368f99395dbf0b941b73a9691cea19cc156a180e6fb6
DIST xf86-input-wacom-0.31.0.tar.bz2 592564 SHA256 e7e9723f048071adabc878bf6139342ea39dea5e3a8134452df5a33bef2e3f76 SHA512 6c24394038585d90b9b30c594b773b36b5ea26ea5eaab73519cd2e1b56eb2ad3e1f3991ca3962a70468da32e83105c9619f524afbf4e6c500661c7c62b4261e8 WHIRLPOOL d84326730a73a50c420876c2e81adc836dcf657d746e09b614902c879390230c43d657f748fd015f874ebe11f277c9b586ddaf762e1aac551ff05a74321c48ff
DIST xf86-input-wacom-0.32.0.tar.bz2 594080 SHA256 8c97ac9afc8150a7c45426e2ccb00fe22eb52671024d41884899e55ce21e870d SHA512 57991c8ba69281e85c14a23f4a2e7403f550118ac6cdee3c72798bc4342b5964318eeb5404302296fb7046d9dc49e167d2ed4d2e9441a28e39558e5e575dc21b WHIRLPOOL 1c9412126f21f1cbea4fe90195d1f9d0cd0ac62dc8469d73c8b830c8c750580b6bd951ee2cca7a0e7983d36596a257300c190f3ec4fc2422eb84f950e3383e74
+DIST xf86-input-wacom-0.33.0.tar.bz2 595192 SHA256 24eef830744a388795a318ef743f19c451e394d9ef1332e98e2d54810a70f8e0 SHA512 669d415bfb4c95332737879c7ad487f905d57a7363c41e2037c9f902c63efbc445e41a9adf1b7a12b7416d61b1011127ff86688a3644371b4bbc883adcdd9e6f WHIRLPOOL 8b1366793d3fffbb68e9be80ec6463deb291647cdc7a46acabe24d06c6bd2d76ea19cb242297094162877c619be2fac8ae064cda675d79a0b4763ec03037b35d
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.33.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.33.0.ebuild
new file mode 100644
index 000000000000..3a6d1e2d5388
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.33.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+# depend on libwacom for its udev rules, bug #389633
+RDEPEND="dev-libs/libwacom
+ virtual/udev
+ >=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ x11-proto/randrproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${ED}"/usr/share/hal
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}