summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-21 13:29:55 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-21 15:42:51 -0400
commit69ea157c9d2851d3aa369484fd13fcb1f69f4477 (patch)
treeb8a2981d98914e8ff63208ab5939c3572adf6b81 /x11-drivers
parentx11-drivers/nvidia-drivers: add 460.91.03 (diff)
downloadgentoo-69ea157c9d2851d3aa369484fd13fcb1f69f4477.tar.gz
gentoo-69ea157c9d2851d3aa369484fd13fcb1f69f4477.tar.bz2
gentoo-69ea157c9d2851d3aa369484fd13fcb1f69f4477.zip
x11-drivers/nvidia-drivers: warn about slub_debug issues
May not affect many users but it is hard to diagnose without a hint. Bug: https://bugs.gentoo.org/796329 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-470.57.02.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-470.57.02.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-470.57.02.ebuild
index ea8905ecfe09..a972835bc8a1 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-470.57.02.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-470.57.02.ebuild
@@ -90,6 +90,7 @@ pkg_setup() {
~DRM_KMS_HELPER
~SYSVIPC
~!LOCKDEP
+ ~!SLUB_DEBUG_ON
!DEBUG_MUTEXES"
local ERROR_DRM_KMS_HELPER="CONFIG_DRM_KMS_HELPER: is not set but needed for Xorg auto-detection
of drivers (no custom config), and optional nvidia-drm.modeset=1.
@@ -422,6 +423,12 @@ pkg_postinst() {
use driver && ewarn "The easiest way to fix this is usually to reboot."
fi
+ if [[ $(</proc/cmdline) == *slub_debug=[!-]* ]]; then
+ ewarn "Detected that the current kernel command line is using 'slub_debug=',"
+ ewarn "this may lead to system instability/freezes with this version of"
+ ewarn "${PN}. Bug: https://bugs.gentoo.org/796329"
+ fi
+
if [[ ${NV_LEGACY_MASK} ]]; then
ewarn "You are installing a version of nvidia-drivers known not to work"
ewarn "with a GPU of the current system. If unwanted, add the mask:"