summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2018-02-01 14:10:51 +0100
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2018-02-01 14:10:51 +0100
commit7b38a94c619dc5a9b12adcf963c0d7467fea90e6 (patch)
treebcafb67f5fd7ff656cd88fa0ed8dc592bf72ad56 /x11-drivers
parentx11-misc/xkeyboard-config: version bump to 2.23.1 (diff)
downloadgentoo-7b38a94c619dc5a9b12adcf963c0d7467fea90e6.tar.gz
gentoo-7b38a94c619dc5a9b12adcf963c0d7467fea90e6.tar.bz2
gentoo-7b38a94c619dc5a9b12adcf963c0d7467fea90e6.zip
x11-drivers/xf86-input-wacom: version bump to 0.36.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/Manifest1
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-wacom/Manifest b/x11-drivers/xf86-input-wacom/Manifest
index 8cb813a581c2..ab7988b64c4c 100644
--- a/x11-drivers/xf86-input-wacom/Manifest
+++ b/x11-drivers/xf86-input-wacom/Manifest
@@ -1,2 +1,3 @@
DIST xf86-input-wacom-0.34.0.tar.bz2 598624 BLAKE2B 9b8b39f859a007c89ff1eb24711a2cc6a90b3106b8a3ceb2bc3c7064c14c5079e8ab08e248309ab08716da5c2e593046dd78b3d989167762c794af95b85ae95f SHA512 d0aae70853f73d989d168e054bb21ddbd2114ec6c012b1c5f949838bb20a7fe75711211886dd649ec0e9449d199da17b4ff156d5d672ad02c8b2e0b667cc40ad
DIST xf86-input-wacom-0.35.0.tar.bz2 601314 BLAKE2B 59c2b03b79d141b71583ce3ea6ac4957e345322b67e78f24333a3f045316aa878dbcca6a575f7daf490e2991494215d83bf28bb9ec6b8a8c133abc57d559dc44 SHA512 9586348e8da91651bc9a9ee9e74dd77f4311060538dcb228681b98300f7624401878190322dcbc4e798bd1eeeb7d2900abc3f5e949a583b6cda44821b8821058
+DIST xf86-input-wacom-0.36.0.tar.bz2 611678 BLAKE2B b3fc8310514e6e07c3c25fceeb982d66e9e10730028af769cd331578a48720666a0872b625beb15c7f68bbb291293dfe4c4e305411310c67bb2bd148e7d570d8 SHA512 48e4cf945eb0f5c7c65d46153756372bbfd6d1f101cd90f609c71cc21b36fa671d98c7be0b52d519775c7e7b875ec441d4308cf70d7897198600553e7a93ccc5
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0.ebuild
new file mode 100644
index 000000000000..1fbc8bdbfe29
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://git.code.sf.net/p/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+# depend on libwacom for its udev rules, bug #389633
+RDEPEND="dev-libs/libwacom
+ virtual/udev
+ >=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ x11-proto/randrproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${ED}"/usr/share/hal
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 3 17; then
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ else
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present HID_WACOM; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " HID support --->"
+ ewarn " Special HID drivers --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ fi
+
+}