summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-01-28 23:03:50 -0800
committerMatt Turner <mattst88@gentoo.org>2017-01-28 23:05:18 -0800
commitaafa644775d31150722aef2a6a68925a016aaa72 (patch)
tree97e0e5a96b16b37506f3539327df29bd4eaeb9a0 /x11-drivers
parentnet-nds/openldap: security and patch cleanup wrt bug #560424 (diff)
downloadgentoo-aafa644775d31150722aef2a6a68925a016aaa72.tar.gz
gentoo-aafa644775d31150722aef2a6a68925a016aaa72.tar.bz2
gentoo-aafa644775d31150722aef2a6a68925a016aaa72.zip
x11-drivers/xf86-video-vesa: Check for CONFIG_DEVMEM.
Bug: https://bugs.gentoo.org/577360
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-vesa/xf86-video-vesa-2.3.4.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.3.4.ebuild b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.3.4.ebuild
index 75d45e5b2d3d..101f1d006491 100644
--- a/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.3.4.ebuild
+++ b/x11-drivers/xf86-video-vesa/xf86-video-vesa-2.3.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit xorg-2
+inherit linux-info xorg-2
DESCRIPTION="Generic VESA video driver"
KEYWORDS="-* alpha amd64 ia64 x86 ~amd64-fbsd ~x86-fbsd"
@@ -12,3 +12,16 @@ IUSE=""
RDEPEND=">=x11-base/xorg-server-1.6
>=x11-libs/libpciaccess-0.12.901"
DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists || ! linux_chkconfig_present DEVMEM; then
+ echo
+ ewarn "This driver requires /dev/mem support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Character devices --->"
+ ewarn " [*] /dev/mem virtual device support"
+ echo
+ fi
+}