summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-05-31 12:09:58 -0700
committerMatt Turner <mattst88@gentoo.org>2020-05-31 12:14:55 -0700
commitfa144d0570467f7badc89308e0d3f4d7817ee7a4 (patch)
tree789b4a93aab4f05f715396bfe600f51c80d42242 /x11-drivers
parentkde-frameworks/extra-cmake-modules: stable 5.70.0 for ppc64 (diff)
downloadgentoo-fa144d0570467f7badc89308e0d3f4d7817ee7a4.tar.gz
gentoo-fa144d0570467f7badc89308e0d3f4d7817ee7a4.tar.bz2
gentoo-fa144d0570467f7badc89308e0d3f4d7817ee7a4.zip
x11-drivers/xf86-video-intel: Version bump to 2.99.917_p20200515
Closes: https://bugs.gentoo.org/726440 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-intel/Manifest1
-rw-r--r--x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20200515.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-intel/Manifest b/x11-drivers/xf86-video-intel/Manifest
index b367790c6387..875f82df9700 100644
--- a/x11-drivers/xf86-video-intel/Manifest
+++ b/x11-drivers/xf86-video-intel/Manifest
@@ -1 +1,2 @@
DIST xf86-video-intel-2.99.917_p20200310.tar.bz2 1249330 BLAKE2B 7ba7566b946cf2c4ce60170912fe517f8c004a477a0edc2a1a9c4dbc476f3bdbea5b39a3ade4d15854cda2cc1146eca47d5fe8b311dfe36cd5ac39cf390142ea SHA512 764517e2413937ec8486d473e0cb0b98146fbaa2cff15cb01757f2263c29a2fa9279338fc801bdafe4e6b38428f8e771a7ee14fa223ba5711a4369e719258cd0
+DIST xf86-video-intel-2.99.917_p20200515.tar.bz2 1250303 BLAKE2B 81fca6a4ccfd01c49f70b741e80080e410044bcc51345ff886ec1d74e9ed1020263927ec1a67052ddcfded0f4027369a87b47ebcdbbf5066d813a7e82fae290f SHA512 29fea01332438ad7616bae56a926f5c6fa08f93f67c23a0bb38f775719f12b15fba5bcb096c0665948f80d3ff6b7c108f360e44aae008192ef6c9b21187b4bbb
diff --git a/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20200515.ebuild b/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20200515.ebuild
new file mode 100644
index 000000000000..6a0a127e4582
--- /dev/null
+++ b/x11-drivers/xf86-video-intel/xf86-video-intel-2.99.917_p20200515.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DRI=dri
+XORG_EAUTORECONF=yes
+inherit linux-info xorg-3 flag-o-matic
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ COMMIT_ID="5ca3ac1a90af177eb111a965e9b4dd8a27cc58fc"
+ SRC_URI="https://gitlab.freedesktop.org/xorg/driver/xf86-video-intel/-/archive/${COMMIT_ID}/${P}.tar.bz2"
+ S="${WORKDIR}/${PN}-${COMMIT_ID}"
+fi
+
+DESCRIPTION="X.Org driver for Intel cards"
+
+IUSE="debug +sna tools +udev uxa xvmc"
+
+REQUIRED_USE="
+ || ( sna uxa )
+"
+RDEPEND="
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXScrnSaver
+ >=x11-libs/pixman-0.27.1
+ >=x11-libs/libdrm-2.4.52[video_cards_intel]
+ >=x11-base/xorg-server-1.18
+ tools? (
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libxshmfence
+ x11-libs/libXtst
+ )
+ udev? (
+ virtual/libudev:=
+ )
+ xvmc? (
+ x11-libs/libXvMC
+ >=x11-libs/libxcb-1.5
+ x11-libs/xcb-util
+ )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-gcc-pr65873.patch
+)
+
+src_configure() {
+ replace-flags -Os -O2
+ XORG_CONFIGURE_OPTIONS=(
+ --disable-dri1
+ $(use_enable debug)
+ $(use_enable dri)
+ $(use_enable dri dri3)
+ $(usex dri "--with-default-dri=3")
+ $(use_enable sna)
+ $(use_enable tools)
+ $(use_enable udev)
+ $(use_enable uxa)
+ $(use_enable xvmc)
+ )
+ xorg-3_src_configure
+}
+
+pkg_postinst() {
+ if linux_config_exists && \
+ kernel_is -lt 4 3 && ! linux_chkconfig_present DRM_I915_KMS; then
+ echo
+ ewarn "This driver requires KMS support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Graphics support --->"
+ ewarn " Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) --->"
+ ewarn " <*> Intel 830M, 845G, 852GM, 855GM, 865G (i915 driver) --->"
+ ewarn " i915 driver"
+ ewarn " [*] Enable modesetting on intel by default"
+ echo
+ fi
+}