summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/dnd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/dnd')
-rw-r--r--x11-libs/dnd/Manifest1
-rw-r--r--x11-libs/dnd/dnd-1.1-r1.ebuild40
-rw-r--r--x11-libs/dnd/files/Makefile-fix.patch44
-rw-r--r--x11-libs/dnd/files/dnd-1.1-gentoo.diff35
-rw-r--r--x11-libs/dnd/metadata.xml8
5 files changed, 128 insertions, 0 deletions
diff --git a/x11-libs/dnd/Manifest b/x11-libs/dnd/Manifest
new file mode 100644
index 000000000000..681384705cd6
--- /dev/null
+++ b/x11-libs/dnd/Manifest
@@ -0,0 +1 @@
+DIST dnd.1.1.tgz 227598 RMD160 eac0744baa344024db2e40c0582c11d722baba48 SHA1 0376e8afe4fe5ed4b2f4fc2a447a332496ab7174 SHA256 ffd9b74f1bf8e5c18a4745ef89e9c6618f9507ec09a010c4bf15481a3f130804
diff --git a/x11-libs/dnd/dnd-1.1-r1.ebuild b/x11-libs/dnd/dnd-1.1-r1.ebuild
new file mode 100644
index 000000000000..a9f057027546
--- /dev/null
+++ b/x11-libs/dnd/dnd-1.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs eutils
+
+S=${WORKDIR}/DND/DNDlib
+DESCRIPTION="OffiX' Drag'n'drop library"
+HOMEPAGE="http://leb.net/offix"
+SRC_URI="http://leb.net/offix/${PN}.${PV}.tgz"
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+
+RDEPEND=">=x11-libs/libX11-1.0.0
+ >=x11-libs/libXmu-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libICE-1.0.0
+ >=x11-libs/libSM-1.0.0
+ >=x11-libs/libXaw-1.0.1
+ >=x11-proto/xproto-7.0.4"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.diff || die
+ epatch "${FILESDIR}"/Makefile-fix.patch || die
+}
+
+src_compile() {
+ tc-export CC CXX RANLIB AR
+ econf --with-x || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+}
diff --git a/x11-libs/dnd/files/Makefile-fix.patch b/x11-libs/dnd/files/Makefile-fix.patch
new file mode 100644
index 000000000000..a22a1b888ce7
--- /dev/null
+++ b/x11-libs/dnd/files/Makefile-fix.patch
@@ -0,0 +1,44 @@
+--- Makefile.in.orig 1997-05-22 22:18:22.000000000 -0400
++++ Makefile.in 2004-06-16 14:41:19.673035936 -0400
+@@ -16,7 +16,7 @@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+-LIB_DIR = @libdir@
++LIB_DIR = $(DESTDIR)@libdir@
+-INC_DIR = @includedir@/OffiX
++INC_DIR = $(DESTDIR)@includedir@/OffiX
+
+ COMPILE = $(CC) $(INCLUDES) $(CFLAGS) -c
+@@ -42,19 +42,22 @@
+ $(COMPILE) dndtest.c
+ $(LINK) dndtest.o -L. -lDnd $(LIBS)
+
+-libDnd.a: DragAndDrop.c
+- rm -f DragAndDrop.o
+- $(COMPILE) DragAndDrop.c
++libDnd.a: DragAndDropC.o
+ rm -f libDnd.a
+- $(AR) cru libDnd.a DragAndDrop.o
++ $(AR) cru libDnd.a DragAndDropC.o
+ $(RANLIB) libDnd.a
+
+-libDnd++.a: DragAndDrop.c
+- rm -f DragAndDrop.o DragAndDrop.cxx
+- ln -s DragAndDrop.c DragAndDrop.cxx
+- $(CXXCOMPILE) DragAndDrop.cxx
++DragAndDropC.o: DragAndDrop.c
++ rm -f DragAndDropC.o
++ $(COMPILE) DragAndDrop.c -o DragAndDropC.o
++
++DragAndDropCpp.o: DragAndDrop.c
++ rm -f DragAndDropCpp.o
++ $(CXXCOMPILE) DragAndDrop.c -o DragAndDropCpp.o
++
++libDnd++.a: DragAndDropCpp.o
+ rm -f libDnd++.a
+- $(AR) cru libDnd++.a DragAndDrop.o
++ $(AR) cru libDnd++.a DragAndDropCpp.o
+ $(RANLIB) libDnd++.a
+
+ clean:
diff --git a/x11-libs/dnd/files/dnd-1.1-gentoo.diff b/x11-libs/dnd/files/dnd-1.1-gentoo.diff
new file mode 100644
index 000000000000..970c5e473650
--- /dev/null
+++ b/x11-libs/dnd/files/dnd-1.1-gentoo.diff
@@ -0,0 +1,35 @@
+--- DragAndDrop.c.orig Tue Sep 25 21:14:11 2001
++++ DragAndDrop.c Tue Sep 25 21:14:16 2001
+@@ -81,23 +81,23 @@
+
+ static CursorData DndCursor[DndEND]={
+ { 0,0,NULL,NULL,0,0,0 },
+- { grey_width, grey_height,grey_bits,grey_mask_bits,
++ { grey_width, grey_height,(char*)grey_bits,(char*)grey_mask_bits,
+ grey_x_hot,grey_y_hot},
+- { file_width,file_height,file_bits,file_mask_bits,
++ { file_width,file_height,(char*)file_bits,(char*)file_mask_bits,
+ file_x_hot,file_y_hot},
+- { files_width,files_height,files_bits,files_mask_bits,
++ { files_width,files_height,(char*)files_bits,(char*)files_mask_bits,
+ files_x_hot,files_y_hot},
+- { text_width,text_height,text_bits,text_mask_bits,
++ { text_width,text_height,(char*)text_bits,(char*)text_mask_bits,
+ text_x_hot,text_y_hot },
+- { dir_width,dir_height,dir_bits,dir_mask_bits,
++ { dir_width,dir_height,(char*)dir_bits,(char*)dir_mask_bits,
+ dir_x_hot,dir_y_hot },
+- { link_width,link_height,link_bits,link_mask_bits,
++ { link_width,link_height,(char*)link_bits,(char*)link_mask_bits,
+ link_x_hot,link_y_hot},
+- { app_width,app_height,app_bits,app_mask_bits,
++ { app_width,app_height,(char*)app_bits,(char*)app_mask_bits,
+ app_x_hot,app_y_hot },
+- { url_width,url_height,url_bits,url_mask_bits,
++ { url_width,url_height,(char*)url_bits,(char*)url_mask_bits,
+ url_x_hot,url_y_hot },
+- { mime_width,mime_height,mime_bits,mime_mask_bits,
++ { mime_width,mime_height,(char*)mime_bits,(char*)mime_mask_bits,
+ mime_x_hot,mime_y_hot }
+ };
+
diff --git a/x11-libs/dnd/metadata.xml b/x11-libs/dnd/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/x11-libs/dnd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>