summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-09-04 00:38:22 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-09-04 00:47:19 +0200
commite60f70db89da06bbf1c3db6cd922b6393927aa1d (patch)
treeca5ae6535e841d647145d0215a02d8b119271e47 /x11-libs/goocanvas
parentx11-libs/pango: version bump 1.40.9 → 1.40.11 (diff)
downloadgentoo-e60f70db89da06bbf1c3db6cd922b6393927aa1d.tar.gz
gentoo-e60f70db89da06bbf1c3db6cd922b6393927aa1d.tar.bz2
gentoo-e60f70db89da06bbf1c3db6cd922b6393927aa1d.zip
x11-libs/goocanvas: version bump 2.0.2 → 2.0.3
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'x11-libs/goocanvas')
-rw-r--r--x11-libs/goocanvas/Manifest1
-rw-r--r--x11-libs/goocanvas/goocanvas-2.0.3.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/x11-libs/goocanvas/Manifest b/x11-libs/goocanvas/Manifest
index 218d6f1b2fbe..46b332f08248 100644
--- a/x11-libs/goocanvas/Manifest
+++ b/x11-libs/goocanvas/Manifest
@@ -1,2 +1,3 @@
DIST goocanvas-1.0.0.tar.bz2 570552 SHA256 1c072ef88567cad241fb4addee26e9bd96741b1503ff736d1c152fa6d865711e SHA512 fef4364b57dc777b6dcceb026f940121a24a8a3792e8d37d320eb47b7747ab0d54d8d7911b4ff77c21ca2b251937c9312da04221bbc246a07bbf4062689de644 WHIRLPOOL fb8592136bacf10d73e3aeeac9366c0614f8cd60e74a30d31e475b1ae9a1ac76c97b64837490f916733d31191a90c121ac0d60e077acef7cc61a861f5b57fde7
DIST goocanvas-2.0.2.tar.xz 502732 SHA256 f20e5fbef8d1a2633033edbd886dd13146a1b948d1813a9c353a80a29295d1d0 SHA512 2b3014b832a5426884aa472fbfabcca171ef90305afccd312583d259517725a1839509e39b13b30c5097bf54ed9b3dfd2bf9eeca4e813a82d14cf1d5a54578ac WHIRLPOOL 714682b70d747e5db94140e5067e4df3c396332cab9f8b112141f39135758cea0a7e07405d796a70d81b95b76ce68ec17c58b317d0508dc413f2e6139dc39c87
+DIST goocanvas-2.0.3.tar.xz 584532 SHA256 6b5b9c25d32c05b9bafc42f5fcc28d55f1426e733e78e9fe4d191cfcd666c800 SHA512 e7db229d029906febc5cc8154cecfe9a7c81497abfb1cdf8e41b8135ef87ef7478dac60bd160adb0d6efbe69680be488c67e78497cb89b1ba295a407af04b786 WHIRLPOOL 8f94970f348d4abdfcc5411a9f5cac6a729db837c6b31693ebcc3af4aee15be898f1f973e58e20f2b6668dc6cc02db26cb9cbbd7f042e79bf25958d6e1a9ffa2
diff --git a/x11-libs/goocanvas/goocanvas-2.0.3.ebuild b/x11-libs/goocanvas/goocanvas-2.0.3.ebuild
new file mode 100644
index 000000000000..41235bfdd14c
--- /dev/null
+++ b/x11-libs/goocanvas/goocanvas-2.0.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Canvas widget for GTK+ using the cairo 2D library for drawing"
+HOMEPAGE="https://wiki.gnome.org/GooCanvas"
+
+LICENSE="LGPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples +introspection python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# python only enables python specific binding override
+RDEPEND="
+ >=x11-libs/gtk+-3.0.0:3
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/cairo-1.10.0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.90.4:3[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.8
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not build demos
+ sed -e 's/^\(SUBDIRS =.*\)demo\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed failed"
+
+ # Python bindings are built/installed manually.
+ sed -e "/SUBDIRS = python/d" -i bindings/Makefile.am bindings/Makefile.in
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-rebuilds \
+ --disable-static \
+ $(use_enable introspection) \
+ --disable-python
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use python; then
+ sub_install() {
+ python_moduleinto $(python -c "import gi;print gi._overridesdir")
+ python_domodule bindings/python/GooCanvas.py
+ }
+ python_foreach_impl sub_install
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${P}/examples/"
+ doins demo/*.[ch] demo/*.png
+ fi
+}