summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/libtinynotify-cli
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/libtinynotify-cli')
-rw-r--r--x11-libs/libtinynotify-cli/Manifest1
-rw-r--r--x11-libs/libtinynotify-cli/libtinynotify-cli-1.2.1.ebuild37
-rw-r--r--x11-libs/libtinynotify-cli/libtinynotify-cli-9999.ebuild48
-rw-r--r--x11-libs/libtinynotify-cli/metadata.xml16
4 files changed, 102 insertions, 0 deletions
diff --git a/x11-libs/libtinynotify-cli/Manifest b/x11-libs/libtinynotify-cli/Manifest
new file mode 100644
index 000000000000..9eb82a78331e
--- /dev/null
+++ b/x11-libs/libtinynotify-cli/Manifest
@@ -0,0 +1 @@
+DIST tinynotify-send-1.2.1.tar.bz2 266078 SHA256 72c5f4451348b0a06dd57efb5de75273e47f7e35ae04df9a3dd1c64be1e71e65 SHA512 f416db09fa95f04d771610af7ae8953192027b8606c53f54efe514c4d33b59e8dc362676004a036c2dd7e7c7cf03b077ee9b753839efbcb181c5724f43efa58d WHIRLPOOL 2e82b67111db19aa52e293feea167e53ef73bf04a043049543082cf9eea64f75bbfe9788e323dd19d081b5cab43ff469e370810fd6bbc70707329cacfb560411
diff --git a/x11-libs/libtinynotify-cli/libtinynotify-cli-1.2.1.ebuild b/x11-libs/libtinynotify-cli/libtinynotify-cli-1.2.1.ebuild
new file mode 100644
index 000000000000..47ae9c118c64
--- /dev/null
+++ b/x11-libs/libtinynotify-cli/libtinynotify-cli-1.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils
+
+MY_PN=tinynotify-send
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Common CLI routines for tinynotify-send & sw-notify-send"
+HOMEPAGE="https://github.com/mgorny/tinynotify-send/"
+SRC_URI="mirror://github/mgorny/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="x11-libs/libtinynotify"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+DOCS=( README )
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc gtk-doc)
+ --disable-regular
+ --disable-system-wide
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libtinynotify-cli/libtinynotify-cli-9999.ebuild b/x11-libs/libtinynotify-cli/libtinynotify-cli-9999.ebuild
new file mode 100644
index 000000000000..e41b2f60b235
--- /dev/null
+++ b/x11-libs/libtinynotify-cli/libtinynotify-cli-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/tinynotify-send.git"
+
+inherit git-r3
+#endif
+
+inherit autotools-utils
+
+MY_PN=tinynotify-send
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Common CLI routines for tinynotify-send & sw-notify-send"
+HOMEPAGE="https://bitbucket.org/mgorny/tinynotify-send/"
+SRC_URI="https://www.bitbucket.org/mgorny/${MY_PN}/downloads/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="x11-libs/libtinynotify:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+DEPEND="${DEPEND}
+ >=dev-util/gtk-doc-1.18"
+#endif
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc gtk-doc)
+ --disable-regular
+ --disable-system-wide
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libtinynotify-cli/metadata.xml b/x11-libs/libtinynotify-cli/metadata.xml
new file mode 100644
index 000000000000..feaa57e4dc77
--- /dev/null
+++ b/x11-libs/libtinynotify-cli/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/tinynotify-send/issues/</bugs-to>
+ <remote-id type="bitbucket">mgorny/tinynotify-send</remote-id>
+ </upstream>
+</pkgmetadata>