summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-04-10 10:26:29 -0700
committerMatt Turner <mattst88@gentoo.org>2019-04-10 10:28:36 -0700
commitdfc4f932e39bd052cab7b40d523acedbc1f0a448 (patch)
treed84051ac32d0d565461e48987f141fc19b06de62 /x11-libs/pixman
parentdev-ruby/psych: cleanup (diff)
downloadgentoo-dfc4f932e39bd052cab7b40d523acedbc1f0a448.tar.gz
gentoo-dfc4f932e39bd052cab7b40d523acedbc1f0a448.tar.bz2
gentoo-dfc4f932e39bd052cab7b40d523acedbc1f0a448.zip
x11-libs/pixman: Version bump to 0.38.4
Closes: https://bugs.gentoo.org/683042 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/pixman')
-rw-r--r--x11-libs/pixman/Manifest1
-rw-r--r--x11-libs/pixman/pixman-0.38.4.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/x11-libs/pixman/Manifest b/x11-libs/pixman/Manifest
index 82ca1b7841b7..3e2f8c58e165 100644
--- a/x11-libs/pixman/Manifest
+++ b/x11-libs/pixman/Manifest
@@ -1,3 +1,4 @@
DIST pixman-0.36.0.tar.bz2 739957 BLAKE2B 05834dbed8a5bfed607a20f78523e7441f5b78a7a01c7d302c48b8f15dcda37111a8a99e7119b84a0a8a26b55fa93db1c2af316359095cb7db0d8a9e263a1eb7 SHA512 ed99c85a8ce11f52659da61bff599c0405ae0069c30434bdef7238bc9f18e83e6d534cddf38c14d753943edbaeba580c5005ad7575f27e469ca7be7878678d21
DIST pixman-0.38.0.tar.gz 891291 BLAKE2B 8d057fba6d85ab4d2bb83903e8f1a6ac05659be4d0645782f5cf4c190e7b27fa0e7d6b2718ab111bd8ded9b617c7aad42dbfdf2169d49816b7eaf6e6673c6a5f SHA512 1b0205dbe9d9185c68813ce577a889f3c83e83fbd9955c3a72d411c3b476e6be93fc246b5b6ef4ee17e2bb8eb6fb5559e01dff7feb6a6c4c6314f980e960d690
DIST pixman-0.38.2.tar.gz 897487 BLAKE2B 0e1dbd24d5510687ac17f15c32fb271c33e9c3f652e689d9ba2a01c9c806696e2020a94fa4fc0892f5b44e2f4b8cd1539142ce443b43d19f9155415033ce75ea SHA512 e809b7bcc81f53067dc70fceb1b8809d3b6b7166b9689ed4e9455f1eb94d61d90cc236aac19e330851f52c074e26a74a5c402a3bbcdef41fd3b6aebc57150539
+DIST pixman-0.38.4.tar.gz 897926 BLAKE2B 2c27069411e709391a1cc0af6c37acf2f06b4fad433a3197e24a0636d5d828ddbf1ca339d91470514d75e126452bc2300d14a2b862671bd11a8b85057d86b31c SHA512 b66dc23c0bc7327cb90085cbc14ccf96ad58001a927f23af24e0258ca13f32d4255535862f1efcf00e9e723410aa9f51edf26fb01c8cde49379d1225acf7b5af
diff --git a/x11-libs/pixman/pixman-0.38.4.ebuild b/x11-libs/pixman/pixman-0.38.4.ebuild
new file mode 100644
index 000000000000..58862e4166be
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.38.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/pixman/pixman.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson multilib-minimal
+
+DESCRIPTION="Low-level pixel manipulation routines"
+HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+ SRC_URI="https://www.x.org/releases/individual/lib/${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="altivec cpu_flags_arm_iwmmxt cpu_flags_arm_iwmmxt2 loongson2f cpu_flags_x86_mmxext neon cpu_flags_x86_sse2 cpu_flags_x86_ssse3"
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature cpu_flags_arm_iwmmxt iwmmxt)
+ $(meson_use cpu_flags_arm_iwmmxt2 iwmmxt2)
+ $(meson_feature cpu_flags_x86_mmxext mmx)
+ $(meson_feature cpu_flags_x86_sse2 sse2)
+ $(meson_feature cpu_flags_x86_ssse3 ssse3)
+ $(meson_feature altivec vmx)
+ $(meson_feature neon neon)
+ $(meson_feature loongson2f loongson-mmi)
+ -Dgtk=disabled
+ -Dlibpng=disabled
+ -Dopenmp=auto # only used in unit tests
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson test -v -C "${BUILD_DIR}" -t 100
+}
+
+multilib_src_install() {
+ meson_src_install
+}