summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-05-17 16:38:39 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-05-17 16:38:39 +0200
commit71d7d206cf4b8effd4beb1124b2570d355df2b19 (patch)
tree5befc3305073f5812bcc495049097fb7a4ef7a88 /x11-libs/xcb-util-cursor
parentx11-proto/xproto: version bump (diff)
downloadgentoo-71d7d206cf4b8effd4beb1124b2570d355df2b19.tar.gz
gentoo-71d7d206cf4b8effd4beb1124b2570d355df2b19.tar.bz2
gentoo-71d7d206cf4b8effd4beb1124b2570d355df2b19.zip
x11-libs/xcb-util-cursor: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-libs/xcb-util-cursor')
-rw-r--r--x11-libs/xcb-util-cursor/Manifest1
-rw-r--r--x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-cursor/Manifest b/x11-libs/xcb-util-cursor/Manifest
index 6c7a2afaf7eb..0d88f3785563 100644
--- a/x11-libs/xcb-util-cursor/Manifest
+++ b/x11-libs/xcb-util-cursor/Manifest
@@ -1,2 +1,3 @@
DIST xcb-util-cursor-0.1.1.tar.bz2 280852 SHA256 517a1febcede3bc994e356c4c066e297a12ca219063b7d39047e29c7a8860652 SHA512 599f9074a9801615a29374a96649c2d9d8de8abd053b7ddb245b7cc50a1c9c94610a8df996a7a79a831ade3d903335fdf7ac299e6b33e735ab087c3fe5923d71 WHIRLPOOL b73856c19e451af35b07de3bc3706ab0374c3c79dcbbc5d19f3cb03324a86d5422a46d51e63a916f53afb5f45d3b689d25d4ea58baa880d42a13fb0dd6693108
DIST xcb-util-cursor-0.1.2.tar.bz2 289714 SHA256 ed65367b810d47ab637011585135f4a84dd12e235dddcd3b26e0cfb3be21fb3a SHA512 13b9dc0e9f8a61fc72ef6ec722d574ba46c5eacdaf0785d301a3cca00de00b772b6b7fa0b6484f54b4ee19d384a46b3bbf29935bf15ffdde23b004567fc4a85e WHIRLPOOL 7f484e976600dac89762c70135d913ab6a003fd87415f06c92faebca24e5022c561131e3e7e7741df04bd2fd00d6d7ce9b0adf1e803ff705e94fb48dcf624581
+DIST xcb-util-cursor-0.1.3.tar.bz2 295224 SHA256 05a10a0706a1a789a078be297b5fb663f66a71fb7f7f1b99658264c35926394f SHA512 be5eee7b268b18f356d6aae04820a7e1c51397dac9020d876df379e833200255b5194269541c245a9b4ac286edad4cfe44dae8e4fcfd16a4726dd7553c104c21 WHIRLPOOL e7c0c586e3b64237d6ba8ce94d90c4c42e8c2bf555a433d44a000ea547c527808d4ea37d58c7dd1c2abf6c1b901c07b49a0e7716bcbb5059a49f1d26acceb404
diff --git a/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3.ebuild b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3.ebuild
new file mode 100644
index 000000000000..545353ce56fc
--- /dev/null
+++ b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_MODULE=/
+XORG_BASE_INDIVIDUAL_URI=https://xcb.freedesktop.org/dist
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-cursor"
+EGIT_HAS_SUBMODULES=yes
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="https://xcb.freedesktop.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-image-0.3.9-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-renderutil-0.3.9[${MULTILIB_USEDEP}]
+ >=x11-proto/xcb-proto-1.8-r3:=[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24:=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-util/gperf-3.0.1
+ test? ( >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}] )"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc doxygen)
+ )
+
+ xorg-2_src_configure
+}