summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/xpa
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/xpa')
-rw-r--r--x11-libs/xpa/Manifest1
-rw-r--r--x11-libs/xpa/files/xpa-2.1.8-makefile.patch84
-rw-r--r--x11-libs/xpa/metadata.xml17
-rw-r--r--x11-libs/xpa/xpa-2.1.15.ebuild55
4 files changed, 157 insertions, 0 deletions
diff --git a/x11-libs/xpa/Manifest b/x11-libs/xpa/Manifest
new file mode 100644
index 000000000000..4f983325ef0a
--- /dev/null
+++ b/x11-libs/xpa/Manifest
@@ -0,0 +1 @@
+DIST xpa-2.1.15.tar.gz 861859 SHA256 ac0e041f9115757fbcbfeb377cb5833544815a70f2b46f6edfbf6d1239ae690a SHA512 62b453eb138197b452fca8d1ded1df97be54bcfbd13a0d5fecafc206c1589913c7d09593247077fb07c8b66a87ac0b22b95dfe74c49f2bd0abb942942fa87ce8 WHIRLPOOL 7dea8b931a1734c216ccfb79604ef5d291e1ea9230bbf0859895ac132ed2ceb7bc8ca13957d2022c34b641e740febf344b44e897faabf5aec9faf5761cf5213f
diff --git a/x11-libs/xpa/files/xpa-2.1.8-makefile.patch b/x11-libs/xpa/files/xpa-2.1.8-makefile.patch
new file mode 100644
index 000000000000..290309662bb5
--- /dev/null
+++ b/x11-libs/xpa/files/xpa-2.1.8-makefile.patch
@@ -0,0 +1,84 @@
+--- Makefile.in.orig 2008-11-03 12:05:33.000000000 +0000
++++ Makefile.in 2008-11-03 12:07:48.000000000 +0000
+@@ -28,6 +28,11 @@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
++bindir = @bindir@
++libdir = @libdir@
++datadir = @datadir@
++mandir = @mandir@
++includedir = @includedir@
+
+ # The following definition can be set to non-null for special systems
+ # like AFS with replication. It allows the pathnames used for installation
+@@ -37,19 +42,19 @@
+ INSTALL_ROOT =
+
+ # Directory in which to install the .a or .so binary for the XPA library:
+-LIB_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/lib
++LIB_INSTALL_DIR = $(INSTALL_ROOT)$(libdir)
+
+ # Directory in which to install the program wish:
+-BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
++BIN_INSTALL_DIR = $(INSTALL_ROOT)$(bindir)
+
+ # Directory in which to install the include file xpa.h:
+-INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
++INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)
+
+ # Top-level directory for manual entries:
+-MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man
++MAN_INSTALL_DIR = $(INSTALL_ROOT)$(mandir)
+
+ # Top-level directory for share entries:
+-MAN_SHARE_DIR = $(INSTALL_ROOT)$(prefix)/share/xpa
++MAN_SHARE_DIR = $(INSTALL_ROOT)$(datadir)/xpa
+
+ # Platform-specific X compiler flags (include file specifications)
+ X_CFLAGS = @X_CFLAGS@
+@@ -175,7 +180,7 @@
+ $(RANLIB) $(LIB)
+
+ shlib: $(LIB)
+- @(rm -rf lib$(PACKAGE).tmp; mkdir lib$(PACKAGE).tmp; \
++ @(rm -rf lib$(PACKAGE).tmp; mkdir -p lib$(PACKAGE).tmp; \
+ (cd lib$(PACKAGE).tmp && ar x ../lib$(PACKAGE).a); \
+ rm -f lib$(PACKAGE).tmp/xt*.o; \
+ rm -f lib$(PACKAGE).tmp/tcl*.o; \
+@@ -184,7 +189,7 @@
+ rm -rf lib$(PACKAGE).tmp)
+
+ tclxpa: $(LIB)
+- @(rm -rf libtclxpa.tmp; mkdir libtclxpa.tmp; \
++ @(rm -rf libtclxpa.tmp; mkdir -p libtclxpa.tmp; \
+ (cd libtclxpa.tmp && ar x ../lib$(PACKAGE).a); \
+ rm -f libtclxpa.tmp/xt*.o; \
+ CC='$(CC)' CXX=$(CXX) \
+@@ -259,7 +264,7 @@
+ do \
+ if [ ! -d $$i ] ; then \
+ echo "Making directory $$i"; \
+- mkdir $$i; \
++ mkdir -p $$i; \
+ chmod 755 $$i; \
+ else true; \
+ fi; \
+@@ -281,7 +286,7 @@
+ install-man:
+ @if [ ! -d $(MAN_INSTALL_DIR) ] ; then \
+ echo "Making directory $(MAN_INSTALL_DIR)"; \
+- mkdir $(MAN_INSTALL_DIR); \
++ mkdir -p $(MAN_INSTALL_DIR); \
+ chmod 755 $(MAN_INSTALL_DIR); \
+ else true; \
+ fi;
+@@ -292,7 +297,7 @@
+ M="$(MAN_INSTALL_DIR)/man$$E"; \
+ if [ ! -d $$M ] ; then \
+ echo "Making directory $$M"; \
+- mkdir $$M; \
++ mkdir -p $$M; \
+ chmod 755 $$M; \
+ else true; \
+ fi; \
diff --git a/x11-libs/xpa/metadata.xml b/x11-libs/xpa/metadata.xml
new file mode 100644
index 000000000000..4bab88844f54
--- /dev/null
+++ b/x11-libs/xpa/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ The XPA messaging system provides seamless communication between many
+ kinds of Unix programs, including X programs and Tcl/Tk programs.
+ It also provides an easy way for users to communicate with these
+ XPA-enabled programs by executing XPA client commands in the shell or
+ by utilizing such commands in scripts. Because XPA works both at the
+ programming level and the shell level, it is a powerful tool for
+ unifying any analysis environment: users and programmers have great
+ flexibility in choosing the best level or levels at which to access
+ XPA services, and client access can be extended or modified easily
+ at any time.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-libs/xpa/xpa-2.1.15.ebuild b/x11-libs/xpa/xpa-2.1.15.ebuild
new file mode 100644
index 000000000000..92dffa93be42
--- /dev/null
+++ b/x11-libs/xpa/xpa-2.1.15.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Messaging system providing communication between programs"
+HOMEPAGE="http://hea-www.harvard.edu/RD/xpa/"
+SRC_URI="http://hea-www.harvard.edu/saord/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ x11-libs/libXt
+ !<sci-astronomy/ds9-5.3"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.8-makefile.patch
+ sed -i -e "s:\${LINK}:\${LINK} ${LDFLAGS}:" mklib || die
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --enable-threaded-xpans \
+ --with-x \
+ --with-tcl \
+ --with-threads
+}
+
+src_compile() {
+ emake shlib tclxpa
+}
+
+src_install () {
+ dodir /usr/$(get_libdir)
+ emake INSTALL_ROOT="${D}" install
+ insinto /usr/$(get_libdir)/tclxpa
+ doins pkgIndex.tcl
+ mv "${ED}"/usr/$(get_libdir)/libtclxpa* \
+ "${ED}"/usr/$(get_libdir)/tclxpa/ || die
+ dodoc README
+ use doc && dodoc doc/*.pdf && dohtml doc/*.html
+ # build system so crappy not worth patching to a non respondant upstream
+ # and builds static with PIC
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
+}