summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-04-02 15:36:32 -0700
committerMatt Turner <mattst88@gentoo.org>2018-04-02 15:43:53 -0700
commit2fa1a1fa049071b0ea98d1ced640bcc4c0e2c864 (patch)
tree1c6ac22d5454aa262345f42794cfe023aa09fb6f /x11-libs
parentsys-apps/agedu: version bump to 20180329 (diff)
downloadgentoo-2fa1a1fa049071b0ea98d1ced640bcc4c0e2c864.tar.gz
gentoo-2fa1a1fa049071b0ea98d1ced640bcc4c0e2c864.tar.bz2
gentoo-2fa1a1fa049071b0ea98d1ced640bcc4c0e2c864.zip
x11-libs/xcb-util-xrm: Version bump to 1.3
Also depend on libX11 unconditionally, for bug linked below. Closes: https://bugs.gentoo.org/651016
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xcb-util-xrm/Manifest1
-rw-r--r--x11-libs/xcb-util-xrm/xcb-util-xrm-1.3.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-xrm/Manifest b/x11-libs/xcb-util-xrm/Manifest
index 34b17b508614..ded150cc765d 100644
--- a/x11-libs/xcb-util-xrm/Manifest
+++ b/x11-libs/xcb-util-xrm/Manifest
@@ -1,2 +1,3 @@
DIST xcb-util-xrm-1.0.tar.bz2 327196 BLAKE2B 6bba57de372371ca7829a477ddc57f86e1faa86829c7f32e46eb5667505c6b3fd0b5acd2dd74f4f1223bbbba678234948bf5d499019b089e3abe23ffb5631843 SHA512 b49d97b018a231b5642bb05a287eb7720d9e1ffe15024d46a4c7ebf2f9cc37a0a4a3262d9aa963fe9554ca801ba013ad6cb5d3f87b67daf4d69efd180d7ba8fd
DIST xcb-util-xrm-1.2.tar.bz2 324708 BLAKE2B ca5176fb848735b856541930f37e46ec093df6d86a981c87c910bfd64e1a8d5a7e2e20405994dd2a8b9c1200dae48bec0df3a6546be984e3ff316a271b0d84eb SHA512 c6031844d3a197b234cb1b22166c02fe8d03f8a8def836b8c974324a0b6b453889680011406c7940bd04fde1389c5a2ff508f84b080f811ca69cbdb0334994e8
+DIST xcb-util-xrm-1.3.tar.bz2 327586 BLAKE2B 06ba03ba22c9a51cad5045024b63d48f32e5ad38d2cf03035bd1132a04ef4906a71d89030141b407329bd8ec04cb131846be2cb3a95e755a57c2841a45b58fa4 SHA512 ebca5d92c9e2363f58485970a0c3a948b13652ce7acdd51dff918fc2e8bc7fcb69892eb3fc8b5f7eaf721ccd8dc2db42727d206bc5155481ec5e7e41d0c7f304
diff --git a/x11-libs/xcb-util-xrm/xcb-util-xrm-1.3.ebuild b/x11-libs/xcb-util-xrm/xcb-util-xrm-1.3.ebuild
new file mode 100644
index 000000000000..1390d9435c5f
--- /dev/null
+++ b/x11-libs/xcb-util-xrm/xcb-util-xrm-1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_BASE_INDIVIDUAL_URI=""
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="https://xcb.freedesktop.org/"
+SRC_URI="https://github.com/Airblader/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
+ x11-libs/xcb-util[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-libs/libX11[${MULTILIB_USEDEP}]" # Only for tests, but configure.ac requires it
+
+src_configure() {
+ xorg-2_src_configure
+}