summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-01-04 04:26:39 +0200
committerMart Raudsepp <leio@gentoo.org>2018-01-04 19:18:00 +0200
commit69dc05bada5cb4272c7af647306a68bbd9820bc0 (patch)
tree612a53fe78a0f62743b95d6b684d2401abd57b16 /x11-libs
parentx11-libs/wxGTK: Fix versionating variables for current case of no subrelease ... (diff)
downloadgentoo-69dc05bada5cb4272c7af647306a68bbd9820bc0.tar.gz
gentoo-69dc05bada5cb4272c7af647306a68bbd9820bc0.tar.bz2
gentoo-69dc05bada5cb4272c7af647306a68bbd9820bc0.zip
x11-libs/wxGTK: don't eautoreconf or rename configure.in files
wxWidgets doesn't use full autotools (at least not automake), and it maintains an autoconf'ed configure script inside its code repository, which gets (usually) updated after each configure.in update. Because we don't eautoreconf to see a slightly dumb warning about configure.in vs configure.ac, remove the renaming, as the code is buggy and breaks on some non-default PORTAGE_TMPDIR values. I don't intend to ever add back an eautoreconf if at all possible, but if it is, make sure such renaming isn't buggy like this. Also note that other Makefile.in's seem to refer to the preset configure.in's by name (with .in ending), so renaming them is probably wrong as well via such a global "find" approach, at least without patching the references too. The eautoreconf and buggy renaming was already removed on bump for 3.0 SLOT. Closes: https://bugs.gentoo.org/614982 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/wxGTK/wxGTK-3.0.3-r300.ebuild8
1 files changed, 1 insertions, 7 deletions
diff --git a/x11-libs/wxGTK/wxGTK-3.0.3-r300.ebuild b/x11-libs/wxGTK/wxGTK-3.0.3-r300.ebuild
index 6066afd3bb45..6605d6d4ac86 100644
--- a/x11-libs/wxGTK/wxGTK-3.0.3-r300.ebuild
+++ b/x11-libs/wxGTK/wxGTK-3.0.3-r300.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit autotools multilib-minimal
+inherit multilib-minimal
DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit"
HOMEPAGE="https://wxwidgets.org/"
@@ -67,12 +67,6 @@ S="${WORKDIR}/wxWidgets-${PV}"
src_prepare() {
default
- local f
- for f in $(find "${S}" -name configure.in); do
- mv "${f}" "${f/in/ac}" || die
- done
- AT_M4DIR="${S}/build/aclocal" eautoreconf
-
# Versionating
sed -i \
-e "s:\(WX_RELEASE = \).*:\1${WXRELEASE}:"\