summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-06-12 06:33:47 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-06-12 06:34:04 +0000
commit9b1c77f0a2da9c98b82455e5f5a235276a891c0a (patch)
treee068a42fd4279faa1b8787132277482ace21e4ff /x11-libs
parentdev-db/freetds: add 1.00.1 (diff)
downloadgentoo-9b1c77f0a2da9c98b82455e5f5a235276a891c0a.tar.gz
gentoo-9b1c77f0a2da9c98b82455e5f5a235276a891c0a.tar.bz2
gentoo-9b1c77f0a2da9c98b82455e5f5a235276a891c0a.zip
x11-libs/xforms: EAPI 6 bump. Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xforms/Manifest1
-rw-r--r--x11-libs/xforms/xforms-1.2.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-libs/xforms/Manifest b/x11-libs/xforms/Manifest
index 86b23e4dc54d..0dde223814b4 100644
--- a/x11-libs/xforms/Manifest
+++ b/x11-libs/xforms/Manifest
@@ -1 +1,2 @@
DIST xforms-1.0.93sp1.tar.gz 2204088 SHA256 0cbef8c16c478b7fc87cf24be618114f9b7d14dc0a06b61a352bb027dd3b2ca4 SHA512 b352b345f110966741f82645f1282805dd27e4eb16642efedb4f7e0132a109f525da678052b501d1d520014bb7f754f5b53676a83cfab5a249c02db835c66a6a WHIRLPOOL e5d83d3aef7bc06612afa6a64f01bbc101c796ae4baf65198088627fcf9e241285707cf9d92b01927fe5970cc8c0e1f1ceb829037c224e0fbb37f41b4997ab54
+DIST xforms-1.2.4.tar.gz 1438503 SHA256 073aea6514959b81b5a82430df3308abf1072b75c909bb915c0e1ebe86d1a8a3 SHA512 93a37dcb9d5cafbca5a6992ba36234c8f9cf0c658e2a2d664b290f5fc39f1239498d97ea3f88230f097a62ed37813cf3c1bd84e98b92e03f1ac0cecfb62565f8 WHIRLPOOL 08e7c8b9740303a91a8cf61234b62455c06e87c6a79c83a13abf748254fa5a776b0bdfa75c4727ac2425c63e12f2d93397c825b4111d4dc767beb5e82c1e1cef
diff --git a/x11-libs/xforms/xforms-1.2.4.ebuild b/x11-libs/xforms/xforms-1.2.4.ebuild
new file mode 100644
index 000000000000..755556d5f11b
--- /dev/null
+++ b/x11-libs/xforms/xforms-1.2.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="A graphical user interface toolkit for X"
+HOMEPAGE="http://xforms-toolkit.org/"
+SRC_URI="http://git.savannah.gnu.org/cgit/${PN}.git/snapshot/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="doc opengl static-libs"
+
+RDEPEND="
+ virtual/jpeg:0=
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm
+ opengl? ( virtual/opengl )"
+
+DEPEND="
+ ${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( ChangeLog NEWS README )
+
+src_prepare() {
+ default
+ AT_M4DIR=config eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc docs) \
+ $(use_enable opengl gl) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}