summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/bbppp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/bbppp')
-rw-r--r--x11-misc/bbppp/Manifest1
-rw-r--r--x11-misc/bbppp/bbppp-0.2.5-r1.ebuild43
-rw-r--r--x11-misc/bbppp/bbppp-0.2.5.ebuild39
-rw-r--r--x11-misc/bbppp/files/bbppp-0.2.5-gcc3-multiline.patch44
-rw-r--r--x11-misc/bbppp/files/bbppp-0.2.5-overflows.patch17
-rw-r--r--x11-misc/bbppp/files/bbppp-asneeded.patch38
-rw-r--r--x11-misc/bbppp/metadata.xml13
7 files changed, 195 insertions, 0 deletions
diff --git a/x11-misc/bbppp/Manifest b/x11-misc/bbppp/Manifest
new file mode 100644
index 000000000000..47e911eefece
--- /dev/null
+++ b/x11-misc/bbppp/Manifest
@@ -0,0 +1 @@
+DIST bbppp-0.2.5.tar.gz 83421 SHA256 6d606f2e269574b61ad2a223ef38dfe3469cfa7518f5d114f2349545747173b4 SHA512 55d1e4d1a2c97ac5a5d34a48cd877891d8d6acf32083d7bfa90e4941cfbc18a91d056a0ec6b7a96182f72be440f6609caf3bc82c9071c6d0bcfbe95577f04930 WHIRLPOOL 09ee0e37e75c52be0bdccb8fbb518fd1c408340e256b0ea62366bc816cc830a6d265ea80432ee0e8ba768c5d938d3a6b85c026d562e27bd47aed107e27205a34
diff --git a/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild b/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..d3c8e49aa3fe
--- /dev/null
+++ b/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="blackbox ppp frontend/monitor"
+HOMEPAGE="http://sourceforge.net/projects/bbtools/"
+SRC_URI="mirror://sourceforge/bbtools/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}
+ media-fonts/font-adobe-100dpi"
+
+DOCS=( README AUTHORS BUGS ChangeLog NEWS TODO data/README.bbppp )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc3-multiline.patch \
+ "${FILESDIR}"/${PN}-asneeded.patch \
+ "${FILESDIR}"/${P}-overflows.patch
+ eautoreconf
+}
+
+src_install () {
+ default
+ rm "${D}"/usr/share/bbtools/README.bbppp
+}
+
+pkg_postinst() {
+ # don't assume blackbox exists because virtual/blackbox is installed
+ if [[ -x ${ROOT}/usr/bin/blackbox ]] ; then
+ if ! grep bbppp "${ROOT}"/usr/bin/blackbox &>/dev/null ; then
+ sed -e "s/.*blackbox/exec \/usr\/bin\/bbppp \&\n&/" blackbox | cat > blackbox
+ fi
+ fi
+}
diff --git a/x11-misc/bbppp/bbppp-0.2.5.ebuild b/x11-misc/bbppp/bbppp-0.2.5.ebuild
new file mode 100644
index 000000000000..aee5f76cc632
--- /dev/null
+++ b/x11-misc/bbppp/bbppp-0.2.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit autotools eutils
+
+DESCRIPTION="blackbox ppp frontend/monitor"
+HOMEPAGE="http://sourceforge.net/projects/bbtools/"
+SRC_URI="mirror://sourceforge/bbtools/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc3-multiline.patch \
+ "${FILESDIR}"/${PN}-asneeded.patch
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+ dodoc README AUTHORS BUGS ChangeLog NEWS TODO data/README.bbppp || die
+ rm "${D}"/usr/share/bbtools/README.bbppp
+}
+
+pkg_postinst() {
+ # don't assume blackbox exists because virtual/blackbox is installed
+ if [[ -x ${ROOT}/usr/bin/blackbox ]] ; then
+ if ! grep bbppp "${ROOT}"/usr/bin/blackbox &>/dev/null ; then
+ sed -e "s/.*blackbox/exec \/usr\/bin\/bbppp \&\n&/" blackbox | cat > blackbox
+ fi
+ fi
+}
diff --git a/x11-misc/bbppp/files/bbppp-0.2.5-gcc3-multiline.patch b/x11-misc/bbppp/files/bbppp-0.2.5-gcc3-multiline.patch
new file mode 100644
index 000000000000..ef2072faa9af
--- /dev/null
+++ b/x11-misc/bbppp/files/bbppp-0.2.5-gcc3-multiline.patch
@@ -0,0 +1,44 @@
+--- main.cc
++++ main.cc
+@@ -24,25 +24,24 @@
+
+ void Usage()
+ {
+- char* usageOptions = {"Options:\n\
+- -display <display name> X server to connect to\n\
+- -c[onfig] <filename> Alternate config file\n\
+- -n[obb] Fall back on default configuration\n\
+- -v[ersion] Display version number\n\
+- -h[elp] Display this help\n\
+- -geom[etry] <geometry> Set geometry of window\n\
+- -d[ecorated] Show 'normal' decorated window\n\
+- -w[ithdrawn] Place bbtool in the Slit\n\
+- -s[hape] Don't display groundplate\n\
+- -thru[put] Display throughput rate\n\
+- -o[rient] <v|h> Display window widgets horizontally or vertically\n\
+- -com[pact] Display buttons in compact style\n\
+- -notime Dont display time window\n\
+- -nosecs Show uptime in old-style hh:mm format\n\n"};
++ char* usageOptions = {"Options:\n"
++ "-display <display name> X server to connect to\n"
++ "-c[onfig] <filename> Alternate config file\n"
++ "-n[obb] Fall back on default configuration\n"
++ "-v[ersion] Display version number\n"
++ "-h[elp] Display this help\n"
++ "-geom[etry] <geometry> Set geometry of window\n"
++ "-d[ecorated] Show 'normal' decorated window\n"
++ "-w[ithdrawn] Place bbtool in the Slit\n"
++ "-s[hape] Don't display groundplate\n"
++ "-thru[put] Display throughput rate\n"
++ "-o[rient] <v|h> Display window widgets horizontally or vertically\n"
++ "-com[pact] Display buttons in compact style\n"
++ "-notime Dont display time window\n"
++ "-nosecs Show uptime in old-style hh:mm format\n\n"};
+
+ fprintf(stdout,"\n%s version %s \n",BBTOOL,BBTOOL_VERSION);
+- fprintf(stdout,"Usage:\n\
+- %s [options]\n",BBTOOL);
++ fprintf(stdout,"Usage:\n%s [options]\n",BBTOOL);
+ fprintf(stdout, "%s", usageOptions);
+ /*
+ fprintf(stdout,"-t[ype] <0|1|2|3> 0:
diff --git a/x11-misc/bbppp/files/bbppp-0.2.5-overflows.patch b/x11-misc/bbppp/files/bbppp-0.2.5-overflows.patch
new file mode 100644
index 000000000000..0c089bc92f4e
--- /dev/null
+++ b/x11-misc/bbppp/files/bbppp-0.2.5-overflows.patch
@@ -0,0 +1,17 @@
+diff --git a/pppstat.cc b/pppstat.cc
+index 71264e4..ca0f11c 100644
+--- a/pppstat.cc
++++ b/pppstat.cc
+@@ -52,10 +52,10 @@ PPPStat::PPPStat(ToolWindow *toolwindow)
+ lastTimeMil = 0.0;
+ ppp_h = -1;
+ #ifndef ISDN
+- active_interface= new char[4];
++ active_interface= new char[5];
+ strcpy(active_interface,"ppp0");
+ #else
+- active_interface= new char[5];
++ active_interface= new char[6];
+ strcpy(active_interface,"ippp0");
+ #endif
+ connect_status=false;
diff --git a/x11-misc/bbppp/files/bbppp-asneeded.patch b/x11-misc/bbppp/files/bbppp-asneeded.patch
new file mode 100644
index 000000000000..7e8c2b8bcfd4
--- /dev/null
+++ b/x11-misc/bbppp/files/bbppp-asneeded.patch
@@ -0,0 +1,38 @@
+Fixing build with as-needed
+
+https://bugs.gentoo.org/show_bug.cgi?id=248552
+
+--- configure.in
++++ configure.in
+@@ -86,14 +86,9 @@
+ AC_PATH_X
+ AC_PATH_XTRA
+
+-CFLAGS="$CFLAGS $X_CFLAGS"
+-CXXFLAGS="$CXXFLAGS $X_CFLAGS"
+-LDFLAGS="$LDFLAGS $X_LIBS $X_PRE_LIBS"
+ dnl Checks for X libraries.
+-AC_CHECK_LIB(X11, XOpenDisplay, LDFLAGS="$LDFLAGS -lX11",
+- AC_MSG_ERROR(XOpenDisplay not found in -lX11))
+-
+-LDFLAGS="$LDFLAGS $X_EXTRA_LIBS"
++AC_CHECK_LIB([X11], [XOpenDisplay], ,
++ AC_MSG_ERROR(XOpenDisplay not found in -lX11),)
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+--- Makefile.am
++++ Makefile.am
+@@ -1,4 +1,4 @@
+-CPPFLAGS = @CPPFLAGS@ @INTERLACE@ @ISDN@\
++AM_CPPFLAGS = @INTERLACE@ @ISDN@\
+ -DGLOBAL_BB=\"$(datadir)/bbtools/bbppp.bb\" \
+ -DGLOBAL_NOBB=\"$(datadir)/bbtools/bbppp.nobb\"
+
+@@ -16,4 +16,5 @@
+ Basewindow.cc Basewindow.hh \
+ blackboxstyle.hh
+ EXTRA_DIST = BUGS TODO
+-bbppp_LDADD = @X_LIBS@
++bbppp_LDADD = @X_PRE_LIBS@ @X_LIBS@ @X_EXTRA_LIBS@
++bbppp_CFLAGS = @X_PRE_CFLAGS@ @X_CFLAGS@ @X_EXTRA_CFLAGS@
diff --git a/x11-misc/bbppp/metadata.xml b/x11-misc/bbppp/metadata.xml
new file mode 100644
index 000000000000..5527b7f8abac
--- /dev/null
+++ b/x11-misc/bbppp/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ A PPP frontend/monitor for Blackbox.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">bbtools</remote-id>
+ </upstream>
+</pkgmetadata>