summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2016-11-23 17:20:08 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2016-11-23 17:20:08 +0000
commit4ceb654d0c48dd3d1c981d9124086c4e33a8d708 (patch)
treed199e760b06f8510dc52c9780962fda748aa32e4 /x11-misc/lightdm/lightdm-1.19.4.ebuild
parenteclass/{xorg-2,x-modular}: fix slash. (diff)
downloadgentoo-4ceb654d0c48dd3d1c981d9124086c4e33a8d708.tar.gz
gentoo-4ceb654d0c48dd3d1c981d9124086c4e33a8d708.tar.bz2
gentoo-4ceb654d0c48dd3d1c981d9124086c4e33a8d708.zip
x11-misc/lightdm: Remove old ebuilds
Package-Manager: portage-2.2.27
Diffstat (limited to 'x11-misc/lightdm/lightdm-1.19.4.ebuild')
-rw-r--r--x11-misc/lightdm/lightdm-1.19.4.ebuild137
1 files changed, 0 insertions, 137 deletions
diff --git a/x11-misc/lightdm/lightdm-1.19.4.ebuild b/x11-misc/lightdm/lightdm-1.19.4.ebuild
deleted file mode 100644
index 22ff7e282af6..000000000000
--- a/x11-misc/lightdm/lightdm-1.19.4.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-inherit autotools eutils flag-o-matic pam qmake-utils readme.gentoo-r1 systemd versionator xdg-utils
-
-TRUNK_VERSION="$(get_version_component_range 1-2)"
-DESCRIPTION="A lightweight display manager"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/LightDM"
-SRC_URI="https://launchpad.net/${PN}/${TRUNK_VERSION}/${PV}/+download/${P}.tar.xz
- mirror://gentoo/introspection-20110205.m4.tar.bz2"
-
-LICENSE="GPL-3 LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="audit +gtk +introspection kde qt4 qt5 +gnome"
-REQUIRED_USE="|| ( gtk kde )"
-
-COMMON_DEPEND="audit? ( sys-process/audit )
- >=dev-libs/glib-2.32.3:2
- dev-libs/libxml2
- gnome? ( sys-apps/accountsservice )
- virtual/pam
- x11-libs/libX11
- >=x11-libs/libxklavier-5
- introspection? ( >=dev-libs/gobject-introspection-1 )
- qt4? (
- dev-qt/qtcore:4
- dev-qt/qtdbus:4
- dev-qt/qtgui:4
- )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- )"
-RDEPEND="${COMMON_DEPEND}
- >=sys-auth/pambase-20101024-r2"
-DEPEND="${COMMON_DEPEND}
- dev-util/gtk-doc-am
- dev-util/intltool
- gnome? ( gnome-base/gnome-common )
- sys-devel/gettext
- virtual/pkgconfig"
-PDEPEND="gtk? ( x11-misc/lightdm-gtk-greeter )
- kde? ( x11-misc/lightdm-kde )"
-
-DOCS=( NEWS )
-RESTRICT="test"
-
-src_prepare() {
- xdg_environment_reset
-
- sed -i -e 's:getgroups:lightdm_&:' tests/src/libsystem.c || die #412369
- sed -i -e '/minimum-uid/s:500:1000:' data/users.conf || die
-
- einfo "Fixing the session-wrapper variable in lightdm.conf"
- sed -i -e \
- "/session-wrapper/s@^.*@session-wrapper=/etc/${PN}/Xsession@" \
- data/lightdm.conf || die "Failed to fix lightdm.conf"
-
- # use correct version of qmake. bug #566950
- sed -i -e "/AC_CHECK_TOOLS(MOC4/a AC_SUBST(MOC4,$(qt4_get_bindir)/moc)" configure.ac || die
- sed -i -e "/AC_CHECK_TOOLS(MOC5/a AC_SUBST(MOC5,$(qt5_get_bindir)/moc)" configure.ac || die
-
- default
-
- # Remove bogus Makefile statement. This needs to go upstream
- sed -i /"@YELP_HELP_RULES@"/d help/Makefile.am || die
- if has_version dev-libs/gobject-introspection; then
- eautoreconf
- else
- AT_M4DIR=${WORKDIR} eautoreconf
- fi
-}
-
-src_configure() {
- # Set default values if global vars unset
- local _greeter _session _user
- _greeter=${LIGHTDM_GREETER:=lightdm-gtk-greeter}
- _session=${LIGHTDM_SESSION:=gnome}
- _user=${LIGHTDM_USER:=root}
- # Let user know how lightdm is configured
- einfo "Gentoo configuration"
- einfo "Default greeter: ${_greeter}"
- einfo "Default session: ${_session}"
- einfo "Greeter user: ${_user}"
-
- use qt5 && append-cxxflags -std=c++11
-
- # also disable tests because libsystem.c does not build. Tests are
- # restricted so it does not matter anyway.
- econf \
- --localstatedir=/var \
- --disable-static \
- --disable-tests \
- $(use_enable audit libaudit) \
- $(use_enable introspection) \
- $(use_enable qt4 liblightdm-qt) \
- $(use_enable qt5 liblightdm-qt5) \
- --with-user-session=${_session} \
- --with-greeter-session=${_greeter} \
- --with-greeter-user=${_user} \
- --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
-}
-
-src_install() {
- default
-
- # Delete apparmor profiles because they only work with Ubuntu's
- # apparmor package. Bug #494426
- if [[ -d ${D}/etc/apparmor.d ]]; then
- rm -r "${D}/etc/apparmor.d" || die \
- "Failed to remove apparmor profiles"
- fi
-
- insinto /etc/${PN}
- doins data/{${PN},keys}.conf
- doins "${FILESDIR}"/Xsession
- fperms +x /etc/${PN}/Xsession
- # /var/lib/lightdm-data could be useful. Bug #522228
- dodir /var/lib/lightdm-data
-
- prune_libtool_files --all
- rm -rf "${ED}"/etc/init
-
- # Remove existing pam file. We will build a new one. Bug #524792
- rm -rf "${ED}"/etc/pam.d/${PN}{,-greeter}
- pamd_mimic system-local-login ${PN} auth account password session #372229
- pamd_mimic system-local-login ${PN}-greeter auth account password session #372229
- dopamd "${FILESDIR}"/${PN}-autologin #390863, #423163
-
- readme.gentoo_create_doc
-
- systemd_dounit "${FILESDIR}/${PN}.service"
-}