summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-01-13 23:52:41 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-01-13 23:52:41 +0100
commit9eb6e2f69abdc8cc76a78a4e5221a5ed12644cd4 (patch)
tree9be16b942ef73aebaeffeaebcb7e395e93550519 /x11-misc/lightdm
parentnet-fs/samba: split up altabi patches and tarball them (diff)
downloadgentoo-9eb6e2f69abdc8cc76a78a4e5221a5ed12644cd4.tar.gz
gentoo-9eb6e2f69abdc8cc76a78a4e5221a5ed12644cd4.tar.bz2
gentoo-9eb6e2f69abdc8cc76a78a4e5221a5ed12644cd4.zip
x11-misc/lightdm: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'x11-misc/lightdm')
-rw-r--r--x11-misc/lightdm/Manifest1
-rw-r--r--x11-misc/lightdm/lightdm-1.17.3.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/x11-misc/lightdm/Manifest b/x11-misc/lightdm/Manifest
index bf3a1a1b559c..570bb97c2f88 100644
--- a/x11-misc/lightdm/Manifest
+++ b/x11-misc/lightdm/Manifest
@@ -5,3 +5,4 @@ DIST lightdm-1.14.4.tar.xz 483304 SHA256 9d9c753e018c9fcba540141696b2da56f98dc21
DIST lightdm-1.15.3.tar.xz 479432 SHA256 0670c6de84e9edfea3210b42aef688a848fa5366d150a71a67cdf83bc64bda5f SHA512 2fde5b1d01c8bbfa1fa74af9947c4ced9211d0f56d9590c9b5253a51774e2f927a4c6c2e76cde7d34351ae8474bf20e27cf71806c0a4e3a4dffc81b070384344 WHIRLPOOL a4765ee04e9faedfe397b561d17e6ac37ee1738358f7dd00f4be6e4fbabca6a83bd76fe845e4605345053350768363c2027a474a0087d5d37b819a0638c35f54
DIST lightdm-1.16.6.tar.xz 485820 SHA256 f8f5d38886fa3c1f52e92a51663c30aaf6de462a9e4df4407769a7b93bf22a6c SHA512 9a89bb224cb7f6ddc174cd42920ee3d88a205824da5ec4b46fd93fa6bd2cdf35b8127f7784131ac1bb97a9bc2349a0f41402561594ff6d0ec339787a44793c34 WHIRLPOOL a22efdc4823f44f0a9d0aab8eb8e89495ec0d156e9b8fd46a6b38c3704455050f0c65b7c8c4d6614a316ebb4eaa83df0f557730214c51b3206b128bbcfa160b4
DIST lightdm-1.17.2.tar.xz 486492 SHA256 dbdcddc8257308198bc6b4b6bd6307753c2a244ddcd6c2637368f2243b3a1a5b SHA512 07fffab17a917e6d03eac1850c205342e8fe7f627abf3820ebfe3107ef827af4fc4443bcaa7ec447760dcf0de9c2b517472854f7562bb3dc915a23c9742ccb15 WHIRLPOOL 4d4b911565be26f98d10da219e6454f013324ef78a1c9a99c97e785355c53bd8cb0f922340453c514d3e1d019581adadec36ada2c91f37b0bfed2010bb346920
+DIST lightdm-1.17.3.tar.xz 487176 SHA256 a9fcfb5edaad4f8c33dcdd695095791e952720d051eef695e07469ed87fa85b3 SHA512 0624fd994dbb0052c2e6092fa9e8ee3785d541d65c3baf911eff5a4f74e5689395a1079139ed6c30e4ad8db07355d9aede859a58718c873a9684c880efdbb6b0 WHIRLPOOL 988e77d998a843d9d168380d1aa5e16f2f491c52679732442e07b8a7b90ffea45fbf3b239f0f65acaac84626e5b9c933f86981250996c6a3524802953654c892
diff --git a/x11-misc/lightdm/lightdm-1.17.3.ebuild b/x11-misc/lightdm/lightdm-1.17.3.ebuild
new file mode 100644
index 000000000000..3d7e185de11a
--- /dev/null
+++ b/x11-misc/lightdm/lightdm-1.17.3.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils pam readme.gentoo systemd versionator
+
+TRUNK_VERSION="$(get_version_component_range 1-2)"
+DESCRIPTION="A lightweight display manager"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/LightDM"
+SRC_URI="https://launchpad.net/${PN}/${TRUNK_VERSION}/${PV}/+download/${P}.tar.xz
+ mirror://gentoo/introspection-20110205.m4.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="audit +gtk +introspection kde qt4 qt5 +gnome"
+REQUIRED_USE="|| ( gtk kde )"
+
+COMMON_DEPEND="audit? ( sys-process/audit )
+ >=dev-libs/glib-2.32.3:2
+ dev-libs/libxml2
+ gnome? ( sys-apps/accountsservice )
+ virtual/pam
+ x11-libs/libX11
+ >=x11-libs/libxklavier-5
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ )"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-auth/pambase-20101024-r2"
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ gnome? ( gnome-base/gnome-common )
+ sys-devel/gettext
+ virtual/pkgconfig"
+PDEPEND="gtk? ( x11-misc/lightdm-gtk-greeter )
+ kde? ( x11-misc/lightdm-kde )"
+
+DOCS=( NEWS )
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e 's:getgroups:lightdm_&:' tests/src/libsystem.c || die #412369
+ sed -i -e '/minimum-uid/s:500:1000:' data/users.conf || die
+
+ einfo "Fixing the session-wrapper variable in lightdm.conf"
+ sed -i -e \
+ "/session-wrapper/s@^.*@session-wrapper=/etc/${PN}/Xsession@" \
+ data/lightdm.conf || die "Failed to fix lightdm.conf"
+
+ epatch_user
+
+ # Remove bogus Makefile statement. This needs to go upstream
+ sed -i /"@YELP_HELP_RULES@"/d help/Makefile.am || die
+ if has_version dev-libs/gobject-introspection; then
+ eautoreconf
+ else
+ AT_M4DIR=${WORKDIR} eautoreconf
+ fi
+}
+
+src_configure() {
+ # Set default values if global vars unset
+ local _greeter _session _user
+ _greeter=${LIGHTDM_GREETER:=lightdm-gtk-greeter}
+ _session=${LIGHTDM_SESSION:=gnome}
+ _user=${LIGHTDM_USER:=root}
+ # Let user know how lightdm is configured
+ einfo "Gentoo configuration"
+ einfo "Default greeter: ${_greeter}"
+ einfo "Default session: ${_session}"
+ einfo "Greeter user: ${_user}"
+
+ # also disable tests because libsystem.c does not build. Tests are
+ # restricted so it does not matter anyway.
+ econf \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-tests \
+ $(use_enable audit libaudit) \
+ $(use_enable introspection) \
+ $(use_enable qt4 liblightdm-qt) \
+ $(use_enable qt5 liblightdm-qt5) \
+ --with-user-session=${_session} \
+ --with-greeter-session=${_greeter} \
+ --with-greeter-user=${_user} \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ # Delete apparmor profiles because they only work with Ubuntu's
+ # apparmor package. Bug #494426
+ if [[ -d ${D}/etc/apparmor.d ]]; then
+ rm -r "${D}/etc/apparmor.d" || die \
+ "Failed to remove apparmor profiles"
+ fi
+
+ insinto /etc/${PN}
+ doins data/{${PN},keys}.conf
+ doins "${FILESDIR}"/Xsession
+ fperms +x /etc/${PN}/Xsession
+ # /var/lib/lightdm-data could be useful. Bug #522228
+ dodir /var/lib/lightdm-data
+
+ prune_libtool_files --all
+ rm -rf "${ED}"/etc/init
+
+ # Remove existing pam file. We will build a new one. Bug #524792
+ rm -rf "${ED}"/etc/pam.d/${PN}{,-greeter}
+ pamd_mimic system-local-login ${PN} auth account password session #372229
+ pamd_mimic system-local-login ${PN}-greeter auth account password session #372229
+ dopamd "${FILESDIR}"/${PN}-autologin #390863, #423163
+
+ readme.gentoo_create_doc
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+}