summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/tabbed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/tabbed')
-rw-r--r--x11-misc/tabbed/Manifest1
-rw-r--r--x11-misc/tabbed/metadata.xml10
-rw-r--r--x11-misc/tabbed/tabbed-0.6.ebuild48
3 files changed, 59 insertions, 0 deletions
diff --git a/x11-misc/tabbed/Manifest b/x11-misc/tabbed/Manifest
new file mode 100644
index 000000000000..3e233c239029
--- /dev/null
+++ b/x11-misc/tabbed/Manifest
@@ -0,0 +1 @@
+DIST tabbed-0.6.tar.gz 12926 SHA256 7651ea3acbec5d6a25469e8665da7fc70aba2b4fa61a2a6a5449eafdfd641c42 SHA512 bcad873251be6b5de21311531e8d24330003b42790cb94d559a0d1be45408b3e0722c14e7c7f2cefd0717fd2a2d7a100fa08fc4e10e7bb669935909602286553 WHIRLPOOL 072ef8b28907958da40b44b07c40e753459851a11a9e9708fa97de27768841580a39dd16018dd6c8d2949b23fabd9cc1152f41462226094d1d501aed1f1f35cd
diff --git a/x11-misc/tabbed/metadata.xml b/x11-misc/tabbed/metadata.xml
new file mode 100644
index 000000000000..d6e0a0f7eded
--- /dev/null
+++ b/x11-misc/tabbed/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-misc</herd>
+<maintainer>
+<email>jer@gentoo.org</email>
+<name>Jeroen Roovers</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/x11-misc/tabbed/tabbed-0.6.ebuild b/x11-misc/tabbed/tabbed-0.6.ebuild
new file mode 100644
index 000000000000..de4295939f29
--- /dev/null
+++ b/x11-misc/tabbed/tabbed-0.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="Simple generic tabbed fronted to xembed aware applications"
+HOMEPAGE="http://tools.suckless.org/tabbed"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="
+ x11-proto/xproto
+ ${RDEPEND}
+"
+
+src_prepare() {
+ sed config.mk \
+ -e '/^CC/d' \
+ -e 's|/usr/local|/usr|g' \
+ -e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)|g' \
+ -e 's|^LDFLAGS.*|LDFLAGS += $(CFLAGS) $(LIBS)|g' \
+ -e 's|^LIBS.*|LIBS = -lX11|g' \
+ -e 's|{|(|g;s|}|)|g' \
+ -i || die
+
+ sed Makefile \
+ -e 's|{|(|g;s|}|)|g' \
+ -e '/^[[:space:]]*@echo/d' \
+ -e 's|^ @| |g' \
+ -i || die
+
+ restore_config config.h
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+src_install() {
+ default
+ save_config config.h
+}