summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-03-25 12:34:00 +0200
committerMart Raudsepp <leio@gentoo.org>2017-03-25 12:40:06 +0200
commit865cdd57ef94a65a9b75d88fe18384496cae83bc (patch)
tree4892ec2f7422ebfca060995950503978d0d19da1 /x11-misc/trayer
parentprofiles: add the reason to keep gst-plugins-ffmpeg p.mask around (diff)
downloadgentoo-865cdd57ef94a65a9b75d88fe18384496cae83bc.tar.gz
gentoo-865cdd57ef94a65a9b75d88fe18384496cae83bc.tar.bz2
gentoo-865cdd57ef94a65a9b75d88fe18384496cae83bc.zip
x11-misc/trayer: Patch to remove dependency on gdk-pixbuf[X]
Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4295
Diffstat (limited to 'x11-misc/trayer')
-rw-r--r--x11-misc/trayer/files/trayer-1.0-as-needed-and-pre-stripped.patch29
-rw-r--r--x11-misc/trayer/files/trayer-1.0-dont-include-gdk-pixbuf-xlib.patch44
-rw-r--r--x11-misc/trayer/trayer-1.0-r3.ebuild40
3 files changed, 113 insertions, 0 deletions
diff --git a/x11-misc/trayer/files/trayer-1.0-as-needed-and-pre-stripped.patch b/x11-misc/trayer/files/trayer-1.0-as-needed-and-pre-stripped.patch
new file mode 100644
index 000000000000..9db338424220
--- /dev/null
+++ b/x11-misc/trayer/files/trayer-1.0-as-needed-and-pre-stripped.patch
@@ -0,0 +1,29 @@
+From 6d0c1123441633660c2ec4f336e1e800b4dfebb5 Mon Sep 17 00:00:00 2001
+From: Harri Nieminen <moikkis@gmail.com>
+Date: Sat, 25 Mar 2017 12:18:13 +0200
+Subject: [PATCH 2/2] Fix for as-needed and pre-stripped files
+
+Gentoo bugs: #141707, #252098
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 9d7c4fb..faaa85d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -36,9 +36,9 @@ endif
+
+ TARGET = trayer
+ $(TARGET): $(OBJ) $(SYSTRAYOBJ)
+- $(CC) $(LDFLAGS) $(LIBS) $(OBJ) $(SYSTRAYOBJ) -o $@
++ $(CC) $(LDFLAGS) $(OBJ) $(SYSTRAYOBJ) $(LIBS) -o $@
+ ifeq (,$(DEVEL))
+- strip $@
++ true $@
+ endif
+
+ TARGETMAN = $(TARGET).1.gz
+--
+2.12.1
+
diff --git a/x11-misc/trayer/files/trayer-1.0-dont-include-gdk-pixbuf-xlib.patch b/x11-misc/trayer/files/trayer-1.0-dont-include-gdk-pixbuf-xlib.patch
new file mode 100644
index 000000000000..ccb1e12869b8
--- /dev/null
+++ b/x11-misc/trayer/files/trayer-1.0-dont-include-gdk-pixbuf-xlib.patch
@@ -0,0 +1,44 @@
+From 1aa5f4164b86fd0c5cf174c8403442060cad497d Mon Sep 17 00:00:00 2001
+From: Harri Nieminen <moikkis@gmail.com>
+Date: Sat, 25 Mar 2017 12:17:09 +0200
+Subject: [PATCH 1/2] Remove useless include on
+ gdk-pixbuf-xlib/gdk-pixbuf-xlib.h
+
+Also fix underlinking, bug #369591
+
+Thanks for leio@g.o for reporting
+---
+ Makefile.common | 4 ++--
+ plugin.c | 1 -
+ 2 files changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.common b/Makefile.common
+index 0d50340..ec2bc3c 100644
+--- a/Makefile.common
++++ b/Makefile.common
+@@ -16,8 +16,8 @@ endif
+ endif
+
+ CC = gcc
+-LIBS = $(shell pkg-config --libs gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0) -L/usr/X11R6/lib -lXmu
+-INCS = $(shell pkg-config --cflags gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0)
++LIBS = $(shell pkg-config --libs gtk+-2.0 gdk-pixbuf-2.0 gmodule-2.0 x11)
++INCS = $(shell pkg-config --cflags gtk+-2.0 gdk-pixbuf-2.0 gmodule-2.0 x11)
+ CFLAGS = -O2 # overwriten by command line or env. variable
+ CFLAGS += -Wall # always nice to have
+ ifneq (,$(DEVEL))
+diff --git a/plugin.c b/plugin.c
+index 7fd5398..a6f8fbb 100644
+--- a/plugin.c
++++ b/plugin.c
+@@ -2,7 +2,6 @@
+ #include "plugin.h"
+
+ #include <gdk-pixbuf/gdk-pixbuf.h>
+-#include <gdk-pixbuf-xlib/gdk-pixbuf-xlib.h>
+ #include <gdk/gdk.h>
+ #include <string.h>
+
+--
+2.12.1
+
diff --git a/x11-misc/trayer/trayer-1.0-r3.ebuild b/x11-misc/trayer/trayer-1.0-r3.ebuild
new file mode 100644
index 000000000000..adb954195460
--- /dev/null
+++ b/x11-misc/trayer/trayer-1.0-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Lightweight GTK+ based systray for UNIX desktop"
+HOMEPAGE="http://home.gna.org/fvwm-crystal/"
+SRC_URI="http://download.gna.org/fvwm-crystal/trayer/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-dont-include-gdk-pixbuf-xlib.patch
+ "${FILESDIR}"/${P}-as-needed-and-pre-stripped.patch
+)
+
+src_compile() {
+ emake -j1 CC=$(tc-getCC) CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}"
+}
+
+src_install() {
+ dobin trayer
+ doman trayer.1
+ einstalldocs
+}