summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/wbarconf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/wbarconf')
-rw-r--r--x11-misc/wbarconf/Manifest1
-rw-r--r--x11-misc/wbarconf/files/wbarconf-0.7.2.2-install.patch81
-rw-r--r--x11-misc/wbarconf/metadata.xml5
-rw-r--r--x11-misc/wbarconf/wbarconf-0.7.2.2-r1.ebuild34
4 files changed, 121 insertions, 0 deletions
diff --git a/x11-misc/wbarconf/Manifest b/x11-misc/wbarconf/Manifest
new file mode 100644
index 000000000000..5e43836b7bae
--- /dev/null
+++ b/x11-misc/wbarconf/Manifest
@@ -0,0 +1 @@
+DIST wbarconf-0.7.2.2.tar.gz 764073 SHA256 d0d0722b8db107983d22a0d4d00679d55ad0800ea81f3ce29869ee4f864c6089 SHA512 9be4fe4ccceb8432d601806e4e10c19d4072502b63648e1111537e8a693a64d78f2a08f12598bd7ab0b356a1a24ccf138bcd893cb0cccb5bf7fbf80caf9d9eba WHIRLPOOL 7fad64b6cc3aa39729a1f5533910641d5e4ea5bdd6b5ea9f38d0b473c2f39a94ab7c1d985222673da5041fa3593723e74301da366f45620f976cc90612ff3dd2
diff --git a/x11-misc/wbarconf/files/wbarconf-0.7.2.2-install.patch b/x11-misc/wbarconf/files/wbarconf-0.7.2.2-install.patch
new file mode 100644
index 000000000000..040d435bc797
--- /dev/null
+++ b/x11-misc/wbarconf/files/wbarconf-0.7.2.2-install.patch
@@ -0,0 +1,81 @@
+--- wbarconf/install.sh
++++ wbarconf/install.sh
+@@ -1,5 +1,6 @@
+ #!/bin/sh
+ startdir=$1
++version=0.7.2.2
+
+ if [ $(echo $1|wc -w) -eq 0 ];then
+ echo "Usage: install.sh /path/to"
+@@ -8,29 +9,28 @@
+ exit 1
+ fi
+
+-echo "Installing in to $startdir..."
++echo "Installing in to ${startdir}..."
+
++cd "$(dirname "$(readlink -f "$0")")" || exit 1
+
+-mkdir -p $startdir/bin/ || return 1
+-install -m0755 wbarconf $startdir/bin/ || return 1
++mkdir -p "${startdir}"/bin/ || exit 1
++install -m0755 wbarconf "${startdir}"/bin/ || exit 1
+
+-mkdir -p $startdir/share/wbarconf/
+-install -m0644 README $startdir/share/wbarconf/ || return 1
+-install -m0644 COPYING $startdir/share/wbarconf/ || return 1
++mkdir -p "${startdir}"/share/doc/wbarconf-${version}/wbarbacks/ || exit 1
++install -m0644 README "${startdir}"/share/doc/wbarconf-${version}/ || exit 1
++install -m0644 wbarbacks/README "${startdir}"/share/doc/wbarconf-${version}/wbarbacks/ || exit 1
+
+-mkdir -p $startdir/share/locale/ || return 1
+-cp -av locale/* $startdir/share/locale/ || return 1
+-chmod 0755 -R $startdir/share/ || return 1
+-find $startdir/share/locale/ -name wbarconf.po -print | xargs rm -f
+-install -m0644 messages.pot $startdir/share/wbarconf/ || return 1
++find . -type d -name LC_MESSAGES -exec mkdir -p "${startdir}/share/{}" \; || exit 1
++find . -type f -name wbarconf.mo -exec install -m0644 '{}' "${startdir}/share/{}" \; || exit 1
+
+-cp -av wbarbacks $startdir/share/wbarconf/ || return 1
+-chmod 0655 -R $startdir/share/wbarconf/ || return 1
++mkdir -p "${startdir}"/share/wbarconf/wbarbacks/ || exit 1
++install -m0644 messages.pot "${startdir}"/share/wbarconf/ || exit 1
++find ./wbarbacks -type f -name "*.png" -exec install -m0644 '{}' "${startdir}/share/wbarconf/{}" \; || exit 1
+
+-mkdir -p $startdir/share/pixmaps/
+-install -m0644 wbarconf.png $startdir/share/pixmaps/ || return 1
++mkdir -p "${startdir}"/share/pixmaps/ || exit 1
++install -m0644 wbarconf.png "${startdir}"/share/pixmaps/ || exit 1
+
+-mkdir -p $startdir/share/applications/
+-install -m0644 wbarconf.desktop $startdir/share/applications/ || return 1
++mkdir -p "${startdir}"/share/applications/ || exit 1
++install -m0644 wbarconf.desktop "${startdir}"/share/applications/ || exit 1
+
+ echo "Installation complete."
+--- wbarconf/wbarconf.desktop
++++ wbarconf/wbarconf.desktop
+@@ -2,10 +2,10 @@
+ Name=WbarConf
+ Exec=wbarconf
+ Type=Application
+-Icon=wbarconf.png
++Icon=wbarconf
+ Terminal=false
+ StartupNotify=true
+-Categories=GTK;Utility;
++Categories=GTK;Utility;
+ Comment=Configuration tool for wbar
+ Comment[de]=Konfigurationswerkzeug für Wbar
+ Comment[fi]=Asetustyökalu wbar:lle
+--- wbarconf/wbarconf
++++ wbarconf/wbarconf
+@@ -51,7 +51,7 @@
+ print("Gettext error, defaulting to english!")
+ # return message
+
+-wbarversion="0.7.2.1"
++wbarversion="0.7.2.2"
+
+ ITEM_ID = 0
+ ITEM_ICON = 1
diff --git a/x11-misc/wbarconf/metadata.xml b/x11-misc/wbarconf/metadata.xml
new file mode 100644
index 000000000000..731225048652
--- /dev/null
+++ b/x11-misc/wbarconf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/wbarconf/wbarconf-0.7.2.2-r1.ebuild b/x11-misc/wbarconf/wbarconf-0.7.2.2-r1.ebuild
new file mode 100644
index 000000000000..176bc9a5d1f9
--- /dev/null
+++ b/x11-misc/wbarconf/wbarconf-0.7.2.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6"
+
+inherit eutils python
+
+DESCRIPTION="Configuration GUI for x11-misc/wbar"
+HOMEPAGE="http://koti.kapsi.fi/ighea/wbarconf/"
+SRC_URI="http://koti.kapsi.fi/ighea/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=x11-misc/wbar-1.3.3
+ dev-python/pygobject:2
+ dev-python/pygtk:2
+ sys-devel/gettext"
+DEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-install.patch
+}
+
+src_install() {
+ ./install.sh "${D}/usr" || die "./install.sh failed."
+}