summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-12 16:49:42 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-12 16:50:35 +0100
commit28b1a9d0f861a37732bb836b9945f6e2f748c96c (patch)
treedf2b69e0ea9b1f7d3fe91576624ea5ea46122a01 /x11-plugins/enigmail
parentx11-plugins/enigmail: Prepared live ebuild for beta releases. (diff)
downloadgentoo-28b1a9d0f861a37732bb836b9945f6e2f748c96c.tar.gz
gentoo-28b1a9d0f861a37732bb836b9945f6e2f748c96c.tar.bz2
gentoo-28b1a9d0f861a37732bb836b9945f6e2f748c96c.zip
x11-plugins/enigmail: Bump to version 2.0_beta1
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'x11-plugins/enigmail')
-rw-r--r--x11-plugins/enigmail/Manifest1
-rw-r--r--x11-plugins/enigmail/enigmail-2.0_beta1.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/x11-plugins/enigmail/Manifest b/x11-plugins/enigmail/Manifest
index a4a42409ab82..964d1ed343bf 100644
--- a/x11-plugins/enigmail/Manifest
+++ b/x11-plugins/enigmail/Manifest
@@ -1 +1,2 @@
DIST enigmail-1.9.9.tar.gz 1787556 BLAKE2B 729cf7e404b4cc5d964df476e627b476916cd6c834ce5f220a26738bc32eabbd9fd2c4c3cbaccef6e1d8c4b5b7313b54278a4170808f8b722443b338fda87b55 SHA512 39b37305362c88527d897ed95aa9d8457137d5f026359d19b838ab9df531c14099e157afdc8fefae78a6fa2ddded8dbfbeaf84eb91ac6cfbb05ae808731da2cb
+DIST enigmail-2.0-beta1.tar.gz 2116808 BLAKE2B a539e7bf97e12327ae2a7e9fafdc2ad4298f9dd602333aa6d414b4c6770b3279cc0c9e100cb3be6be86c49f17b4c76759676efc963fe04e8fe522a8aad345f47 SHA512 ddbf540c0d628c19c7ddbcd01686dcdec53385113367e9f3ef683e3ebc97e17cbdbe62e7623b7b1be41967f47cd430b4f2d2fba1d0a86773c836ffc6ceb8f548
diff --git a/x11-plugins/enigmail/enigmail-2.0_beta1.ebuild b/x11-plugins/enigmail/enigmail-2.0_beta1.ebuild
new file mode 100644
index 000000000000..9e8d0cbb3958
--- /dev/null
+++ b/x11-plugins/enigmail/enigmail-2.0_beta1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1
+
+DESCRIPTION="Mozilla extension to provide GPG support in mail clients"
+HOMEPAGE="http://www.enigmail.net/"
+
+SLOT="0"
+LICENSE="MPL-2.0 GPL-3"
+IUSE=""
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.code.sf.net/p/enigmail/source"
+ S="${WORKDIR}/${P}"
+else
+ if [[ ${PV} = *_beta* ]] ; then
+ SRC_URI="http://www.enigmail.net/download/beta/${P/_/-}.tar.gz"
+ else
+ SRC_URI="http://www.enigmail.net/download/source/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+ fi
+ S="${WORKDIR}/${PN}"
+fi
+
+RDEPEND="|| (
+ ( >=app-crypt/gnupg-2.0
+ || (
+ app-crypt/pinentry[gtk(-)]
+ app-crypt/pinentry[qt4(-)]
+ app-crypt/pinentry[qt5(-)]
+ )
+ )
+ =app-crypt/gnupg-1.4*
+ )
+ !<mail-client/thunderbird-52.5.0
+ !<www-client/seamonkey-2.49.5.0_p0
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ app-arch/zip
+ dev-lang/perl
+ "
+
+src_compile() {
+ emake ipc public ui package lang stdlib
+ emake xpi
+
+}
+
+src_install() {
+ local emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' build/dist/install.rdf)
+ [[ -n ${emid} ]] || die "Could not scrape EM:ID from install.rdf"
+
+ mv build/enigmail*.xpi build/"${emid}.xpi" || die 'Could not rename XPI to match EM:ID'
+
+ # thunderbird
+ insinto "/usr/share/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}"
+ doins build/"${emid}.xpi"
+
+ # seamonkey
+ insinto "/usr/share/mozilla/extensions/{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}"
+ doins build/"${emid}.xpi"
+}
+
+pkg_postinst() {
+ local peimpl=$(eselect --brief --colour=no pinentry show)
+ case "${peimpl}" in
+ *gtk*|*qt*) ;;
+ *) ewarn "The pinentry front-end currently selected is not one supported by thunderbird."
+ ewarn "You may be prompted for your password in an inaccessible shell!!"
+ ewarn "Please use 'eselect pinentry' to select either the gtk or qt front-end"
+ ;;
+ esac
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "Please restart thunderbird and/or seamonkey in order for them to use"
+ elog "the newly installed version of enigmail."
+ fi
+}