summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/gkrellmlaunch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/gkrellmlaunch')
-rw-r--r--x11-plugins/gkrellmlaunch/Manifest1
-rw-r--r--x11-plugins/gkrellmlaunch/files/gkrellmlaunch-0.5-makefile.patch35
-rw-r--r--x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5.ebuild26
-rw-r--r--x11-plugins/gkrellmlaunch/metadata.xml8
4 files changed, 70 insertions, 0 deletions
diff --git a/x11-plugins/gkrellmlaunch/Manifest b/x11-plugins/gkrellmlaunch/Manifest
new file mode 100644
index 000000000000..5cb0d0fdcf80
--- /dev/null
+++ b/x11-plugins/gkrellmlaunch/Manifest
@@ -0,0 +1 @@
+DIST gkrellmlaunch-0.5.tar.gz 22035 SHA256 e5cfd29cb206139865ef224cd16ab2389fd06648b9f22b56c3809b1c402f30f7 SHA512 be3a6df6a1648a61103d389dcea24454a142d64b1192156787b42546c485ed592dca916394e46bc0413110a90fa1f4e952fef077e9014274e74610efe8573693 WHIRLPOOL 6069c68007e6c4e3e19cdf9d6261101840ee744745723a6ed1b3e0234464e0557d83104a1ff14eaa4991a93a170b8e17006571bfca531920a8a282e0574aa937
diff --git a/x11-plugins/gkrellmlaunch/files/gkrellmlaunch-0.5-makefile.patch b/x11-plugins/gkrellmlaunch/files/gkrellmlaunch-0.5-makefile.patch
new file mode 100644
index 000000000000..31175b664837
--- /dev/null
+++ b/x11-plugins/gkrellmlaunch/files/gkrellmlaunch-0.5-makefile.patch
@@ -0,0 +1,35 @@
+--- Makefile 2002-09-26 15:56:06.000000000 +0200
++++ Makefile_new 2013-03-15 17:26:19.398383410 +0100
+@@ -4,21 +4,25 @@
+ GTK_LIB = `pkg-config gtk+-2.0 --libs`
+
+
+-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) -g
++FLAGS = -fPIC $(GTK_INCLUDE)
+ #LIBS = $(GTK_LIB) $(IMLIB_LIB) -lefence
+ LIBS = $(GTK_LIB) $(IMLIB_LIB)
+
+-LFLAGS = -shared -W1
++LFLAGS = -shared
+
+-CC = gcc $(CFLAGS) $(FLAGS)
++CC = $(CC)
+
+ OBJS = gkrellmlaunch.o
+
++all: gkrellmlaunch.so
++
++%.o: %.c
++ $(CC) $(CFLAGS) $(FLAGS) -c -o $@ $<
++
+ gkrellmlaunch.so: $(OBJS)
+- $(CC) $(OBJS) -o gkrellmlaunch.so $(LFLAGS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(FLAGS) $(OBJS) -o gkrellmlaunch.so $(LFLAGS) $(LIBS)
+
+ clean:
+ rm -f *.o core *.so* *.bak *~
+
+-gkrellmlaunch.o: gkrellmlaunch.c
+-
++gkrellmlaunch.o: gkrellmlaunch.c
+\ No newline at end of file
diff --git a/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5.ebuild b/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5.ebuild
new file mode 100644
index 000000000000..46649ef64ae0
--- /dev/null
+++ b/x11-plugins/gkrellmlaunch/gkrellmlaunch-0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="A Program-Launcher Plugin for GKrellM2"
+SRC_URI="mirror://sourceforge/gkrellmlaunch/${P}.tar.gz"
+HOMEPAGE="http://gkrellmlaunch.sourceforge.net/"
+IUSE=""
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc alpha amd64"
+
+RDEPEND="app-admin/gkrellm[X]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
+}
diff --git a/x11-plugins/gkrellmlaunch/metadata.xml b/x11-plugins/gkrellmlaunch/metadata.xml
new file mode 100644
index 000000000000..3b58c1c8ba42
--- /dev/null
+++ b/x11-plugins/gkrellmlaunch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <upstream>
+ <remote-id type="sourceforge">gkrellmlaunch</remote-id>
+ </upstream>
+</pkgmetadata>