summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/pidgin-indicator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/pidgin-indicator')
-rw-r--r--x11-plugins/pidgin-indicator/Manifest1
-rw-r--r--x11-plugins/pidgin-indicator/metadata.xml11
-rw-r--r--x11-plugins/pidgin-indicator/pidgin-indicator-0.9.ebuild32
3 files changed, 44 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-indicator/Manifest b/x11-plugins/pidgin-indicator/Manifest
new file mode 100644
index 000000000000..c685a4e918cd
--- /dev/null
+++ b/x11-plugins/pidgin-indicator/Manifest
@@ -0,0 +1 @@
+DIST pidgin-indicator-0.9.tar.gz 28350 SHA256 bf7b3c8914a96ef7953adb503b37e0e238682f264a21355fb99e7bf148db6b5c SHA512 bf16a47d44bb184815437c6bc70021777fb8e438838eb916351c59e82879e9bdaebd430ffa77c7d36e6b66d923813bcfb7c17759c8310eb6f9e260def4189ece WHIRLPOOL 29f23d84a327a8f885ef4fa1e64f422bd4b278582601f0d58a564fede66685ed20192453c1018e6ce4b171e5d03b63e00b82014926c03668394805d238f0e475
diff --git a/x11-plugins/pidgin-indicator/metadata.xml b/x11-plugins/pidgin-indicator/metadata.xml
new file mode 100644
index 000000000000..9b198d3f3bd5
--- /dev/null
+++ b/x11-plugins/pidgin-indicator/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">philipl/pidgin-indicator</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-indicator/pidgin-indicator-0.9.ebuild b/x11-plugins/pidgin-indicator/pidgin-indicator-0.9.ebuild
new file mode 100644
index 000000000000..22740c259d1e
--- /dev/null
+++ b/x11-plugins/pidgin-indicator/pidgin-indicator-0.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="Indicator plugin for Pidgin"
+HOMEPAGE="https://github.com/philipl/pidgin-indicator"
+SRC_URI="https://github.com/philipl/pidgin-indicator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libappindicator:2
+ net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -exec rm {} + || die
+}