summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/pidgin-privacy-please
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/pidgin-privacy-please')
-rw-r--r--x11-plugins/pidgin-privacy-please/Manifest1
-rw-r--r--x11-plugins/pidgin-privacy-please/metadata.xml11
-rw-r--r--x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1.ebuild31
3 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-privacy-please/Manifest b/x11-plugins/pidgin-privacy-please/Manifest
new file mode 100644
index 000000000000..6b56fb216b02
--- /dev/null
+++ b/x11-plugins/pidgin-privacy-please/Manifest
@@ -0,0 +1 @@
+DIST pidgin-privacy-please-0.7.1.tar.gz 346421 SHA256 8134bcd5da98fe8b4c9918fd420c7e68b0990e895ed2534396cacbf473f2615c SHA512 4acec4556c209b6ff5b059244d79894efba984cdebaaf5893c67ba384126127614aea676af6deb89561f6d5776abdbdc915061db9e1004c0fea3339d45a6646a WHIRLPOOL d6bb36bda47104dc9fb1bcba519812a61e5adc60c69f0be6da856c37be581ebe016906066df270187800e00a460cbaa393fd8e2c435533d60f8f80acd7f82007
diff --git a/x11-plugins/pidgin-privacy-please/metadata.xml b/x11-plugins/pidgin-privacy-please/metadata.xml
new file mode 100644
index 000000000000..2fbfcfcc5e1d
--- /dev/null
+++ b/x11-plugins/pidgin-privacy-please/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">pidgin-privacy-please</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1.ebuild b/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1.ebuild
new file mode 100644
index 000000000000..ee1d23ddc48d
--- /dev/null
+++ b/x11-plugins/pidgin-privacy-please/pidgin-privacy-please-0.7.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit autotools
+
+DESCRIPTION="pidgin plugin to stop spammers from annoying you"
+HOMEPAGE="http://code.google.com/p/pidgin-privacy-please/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="linguas_de linguas_pl linguas_ru"
+
+RDEPEND="<net-im/pidgin-3[gtk]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -e 's: -Wall -g3::' -i configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" ALL_LINGUAS="${LANGS}" install || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+}