summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmbiff
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmbiff')
-rw-r--r--x11-plugins/wmbiff/Manifest1
-rw-r--r--x11-plugins/wmbiff/files/wmbiff-0.4.27-gnutls-3.patch60
-rw-r--r--x11-plugins/wmbiff/files/wmbiff-0.4.27-gnutls.patch26
-rw-r--r--x11-plugins/wmbiff/files/wmbiff-0.4.27-invalid-strncpy.patch17
-rw-r--r--x11-plugins/wmbiff/metadata.xml5
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.28.ebuild41
6 files changed, 150 insertions, 0 deletions
diff --git a/x11-plugins/wmbiff/Manifest b/x11-plugins/wmbiff/Manifest
new file mode 100644
index 000000000000..b4cadf8454dd
--- /dev/null
+++ b/x11-plugins/wmbiff/Manifest
@@ -0,0 +1 @@
+DIST wmbiff-0.4.28.tar.gz 111398 SHA256 6e2acd3268dad93c596e4eae6ccf4407667f07226cf61dd7cfa312ae5e42dbc1 SHA512 a17fd4b4c3de09a907b7ffccc50f4560a7fddd5cb4dd01c72460806dc55259ba0b587d75f7505171a2a833f6735ddc4ded0a484d4227bfd552cc7343d79d7720 WHIRLPOOL c4a0c54f41a3ae33785364ea3bca808bc5b0c801a87ea33bd569f8fac9bb7632155af5d666bc7b3dbfe10fbebb8b2202fccb49266ded3fd299f2e0ac2749785c
diff --git a/x11-plugins/wmbiff/files/wmbiff-0.4.27-gnutls-3.patch b/x11-plugins/wmbiff/files/wmbiff-0.4.27-gnutls-3.patch
new file mode 100644
index 000000000000..d68512450f8e
--- /dev/null
+++ b/x11-plugins/wmbiff/files/wmbiff-0.4.27-gnutls-3.patch
@@ -0,0 +1,60 @@
+diff -Naur wmbiff-0.4.27.orig/wmbiff/gnutls-common.c wmbiff-0.4.27/wmbiff/gnutls-common.c
+--- wmbiff-0.4.27.orig/wmbiff/gnutls-common.c 2012-07-04 21:45:00.013010829 +0200
++++ wmbiff-0.4.27/wmbiff/gnutls-common.c 2012-07-04 21:48:39.306250592 +0200
+@@ -4,7 +4,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <gnutls/gnutls.h>
+-#include <gnutls/extra.h>
+ #include <gnutls/x509.h>
+ #include <gnutls/openpgp.h>
+ #include <time.h>
+@@ -335,8 +334,8 @@
+ void print_cert_vrfy(gnutls_session session)
+ {
+
+- int status;
+- status = gnutls_certificate_verify_peers(session);
++ int verify_ret, status;
++ verify_ret = gnutls_certificate_verify_peers2(session, &status);
+ printf("\n");
+
+ if (status == GNUTLS_E_NO_CERTIFICATE_FOUND) {
+@@ -509,7 +508,6 @@
+
+ printf("Compression methods:");
+ printf(" ZLIB");
+- printf(", LZO");
+ printf(", NULL\n");
+ }
+
+@@ -637,8 +635,6 @@
+ comp_priority[j++] = GNUTLS_COMP_NULL;
+ if (strncasecmp(comp[i], "ZLI", 3) == 0)
+ comp_priority[j++] = GNUTLS_COMP_ZLIB;
+- if (strncasecmp(comp[i], "LZO", 3) == 0)
+- comp_priority[j++] = GNUTLS_COMP_LZO;
+ }
+ comp_priority[j] = 0;
+ }
+diff -Naur wmbiff-0.4.27.orig/wmbiff/tlsComm.c wmbiff-0.4.27/wmbiff/tlsComm.c
+--- wmbiff-0.4.27.orig/wmbiff/tlsComm.c 2012-07-04 21:45:00.013010829 +0200
++++ wmbiff-0.4.27/wmbiff/tlsComm.c 2012-07-04 21:50:27.897367863 +0200
+@@ -410,7 +410,7 @@
+ tls_check_certificate(struct connection_state *scs,
+ const char *remote_hostname)
+ {
+- int certstat;
++ int verify_ret, certstat;
+ const gnutls_datum *cert_list;
+ int cert_list_size = 0;
+ gnutls_x509_crt cert;
+@@ -419,7 +419,7 @@
+ bad_certificate(scs, "Unable to get certificate from peer.\n");
+ return; /* bad_cert will exit if -skip-certificate-check was not given */
+ }
+- certstat = gnutls_certificate_verify_peers(scs->tls_state);
++ verify_ret = gnutls_certificate_verify_peers2(scs->tls_state, &certstat);
+ if (certstat == GNUTLS_E_NO_CERTIFICATE_FOUND) {
+ bad_certificate(scs, "server presented no certificate.\n");
+ #ifdef GNUTLS_CERT_CORRUPTED
diff --git a/x11-plugins/wmbiff/files/wmbiff-0.4.27-gnutls.patch b/x11-plugins/wmbiff/files/wmbiff-0.4.27-gnutls.patch
new file mode 100644
index 000000000000..738d8f160a7a
--- /dev/null
+++ b/x11-plugins/wmbiff/files/wmbiff-0.4.27-gnutls.patch
@@ -0,0 +1,26 @@
+http://bugs.gentoo.org/268502
+
+--- configure.ac
++++ configure.ac
+@@ -77,13 +77,14 @@
+
+ GNUTLS_MAN_STATUS="This copy of WMBiff was not compiled with GNUTLS."
+ if test "$gnutls" = "ok"; then
+- AM_PATH_LIBGNUTLS(1.0.4, [LIBS="$LIBS $LIBGNUTLS_LIBS"
+- CFLAGS="$CFLAGS $LIBGNUTLS_CFLAGS"
+- CPPFLAGS="$CPPFLAGS $LIBGNUTLS_CFLAGS"
+- GNUTLS_COMMON_O="gnutls-common.o"
+- GNUTLS_MAN_STATUS="This copy of WMBiff was compiled with GNUTLS."
+- AC_CHECK_HEADERS(gnutls/gnutls.h) ],
+- [ echo GNUTLS can be found at ftp://gnutls.hellug.gr/pub/gnutls ])
++ PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 1.0.4],
++ [LIBS="$LIBS $LIBGNUTLS_LIBS"
++ CFLAGS="$CFLAGS $LIBGNUTLS_CFLAGS"
++ CPPFLAGS="$CPPFLAGS $LIBGNUTLS_CFLAGS"
++ GNUTLS_COMMON_O="gnutls-common.o"
++ GNUTLS_MAN_STATUS="This copy of WMBiff was compiled with GNUTLS."
++ AC_CHECK_HEADERS(gnutls/gnutls.h) ],
++ [ echo GNUTLS can be found at ftp://gnutls.hellug.gr/pub/gnutls ])
+ else
+ AC_MSG_RESULT(GNUTLS support requires libz.a and libgdbm.a, so will be disabled)
+ fi
diff --git a/x11-plugins/wmbiff/files/wmbiff-0.4.27-invalid-strncpy.patch b/x11-plugins/wmbiff/files/wmbiff-0.4.27-invalid-strncpy.patch
new file mode 100644
index 000000000000..07f9bad989d6
--- /dev/null
+++ b/x11-plugins/wmbiff/files/wmbiff-0.4.27-invalid-strncpy.patch
@@ -0,0 +1,17 @@
+This corrupted the path for me before, so it couldn't find the file. Presumably since the glibc change to copy stuff backwards.
+
+diff -pudr wmbiff-0.4.27/wmbiff/mboxClient.c wmbiff-0.4.27-mik/wmbiff/mboxClient.c
+--- wmbiff-0.4.27/wmbiff/mboxClient.c 2004-03-28 01:28:58.000000000 +0100
++++ wmbiff-0.4.27-mik/wmbiff/mboxClient.c 2011-09-16 09:54:22.834144487 +0200
+@@ -149,7 +149,10 @@ int mboxCreate(Pop3 pc, const char *str)
+ DM(pc, DEBUG_ERROR, "mbox '%s' is too long.\n", str + 5);
+ memset(pc->path, 0, BUF_BIG);
+ } else {
+- strncpy(pc->path, str + 5, BUF_BIG - 1); /* cut off ``mbox:'' */
++ /* str is always pc.path, so we can't use strncpy */
++ int len = strlen(str + 5);
++ memmove(pc->path, str + 5, min(len, BUF_BIG - 1)); /* cut off ``mbox:'' */
++ pc->path[len] = '\0';
+ }
+ }
+
diff --git a/x11-plugins/wmbiff/metadata.xml b/x11-plugins/wmbiff/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmbiff/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.28.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.28.ebuild
new file mode 100644
index 000000000000..e24cba80611c
--- /dev/null
+++ b/x11-plugins/wmbiff/wmbiff-0.4.28.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="WMBiff is a dock applet for WindowMaker which can monitor up to 5 mailboxes"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmbiff"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="crypt"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ crypt? (
+ >=dev-libs/libgcrypt-1.2.1:0
+ >=net-libs/gnutls-2.2.0
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+S=${WORKDIR}/dockapps
+
+DOCS="ChangeLog FAQ NEWS README TODO wmbiff/sample.wmbiffrc"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.4.27-invalid-strncpy.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable crypt crypto)
+}