summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmclock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmclock')
-rw-r--r--x11-plugins/wmclock/Manifest3
-rw-r--r--x11-plugins/wmclock/metadata.xml13
-rw-r--r--x11-plugins/wmclock/wmclock-1.0.13.ebuild35
-rw-r--r--x11-plugins/wmclock/wmclock-1.0.14.ebuild35
-rw-r--r--x11-plugins/wmclock/wmclock-1.0.15.ebuild34
5 files changed, 120 insertions, 0 deletions
diff --git a/x11-plugins/wmclock/Manifest b/x11-plugins/wmclock/Manifest
new file mode 100644
index 000000000000..884bc5171d21
--- /dev/null
+++ b/x11-plugins/wmclock/Manifest
@@ -0,0 +1,3 @@
+DIST wmclock-1.0.13.tar.gz 45740 SHA256 53a0166d565661d917743bfa3f77cb084e0d6c0ea369f81e17f4a6709e9e9e42
+DIST wmclock-1.0.14.tar.gz 38311 SHA256 9a05bd547bb1f855ea75374cfada9f14ef90592246362a91dcb2c580550db64d SHA512 34bf6e2287477a207e09d35d9ef0b326d2683be31a66d3cc6aa22323b5615cb114e8597d54ea7b3cbc204b689bba05d26e152f196305b82f4ba7220d14af73f6 WHIRLPOOL 85e3b10abc634aafa164d150debf3f320ac4efbb513039f19e60eeafc5fab8dd0c8be80789af26380a571786a9c364c662a8d263f1c0156d968e95a63d28c903
+DIST wmclock-1.0.15.tar.gz 35234 SHA256 4d51e2e584e55bad5aaa714c75d42ca47833b07489e9671f60e9b5ebae35c96f SHA512 908f34e9d41c0fa51df2352ce7a43319810f8ef35be9594126536907257516e7f8818635ff306e67fef81fc25ecba809a9d4152b6e3b7c6943586eabedbe09f9 WHIRLPOOL 565654a66359f9ddef57404a7bd7061092ab0b777c4821df4db862903e17588a8eda1c366637375e7643adb57458b80c20dddc7ac449af42e4474c4e25e0ee85
diff --git a/x11-plugins/wmclock/metadata.xml b/x11-plugins/wmclock/metadata.xml
new file mode 100644
index 000000000000..5515d0958711
--- /dev/null
+++ b/x11-plugins/wmclock/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<longdescription>
+Wmclock is an applet which displays the date and time in a dockable tile.
+Wmclock is specially designed for Window Maker, and features multiple language
+support, twenty-four-hour and twelve-hour (am/pm) time display, and,
+optionally, can run a user-specified program on a mouse click. Wmclock is
+derived from ASClock (now called ASClock classic), a similar clock for the
+AfterStep window manager.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmclock/wmclock-1.0.13.ebuild b/x11-plugins/wmclock/wmclock-1.0.13.ebuild
new file mode 100644
index 000000000000..8af08ba08091
--- /dev/null
+++ b/x11-plugins/wmclock/wmclock-1.0.13.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs
+
+DESCRIPTION="a dockapp that displays time and date (same style as NEXTSTEP(tm) operating systems)"
+SRC_URI="http://www.bluestop.org/wmclock/${P}.tar.gz"
+HOMEPAGE="http://www.bluestop.org/wmclock/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ x11-misc/gccmakedep
+ x11-misc/imake"
+
+src_compile() {
+ emake CC=$(tc-getCC) CDEBUGFLAGS="${CFLAGS}" LDOPTIONS="${LDFLAGS}" || die "make failed"
+}
+
+src_install() {
+ dobin wmclock || die "dobin failed"
+ newman wmclock.man wmclock.1
+ dodoc ChangeLog README
+}
diff --git a/x11-plugins/wmclock/wmclock-1.0.14.ebuild b/x11-plugins/wmclock/wmclock-1.0.14.ebuild
new file mode 100644
index 000000000000..89516b08df8e
--- /dev/null
+++ b/x11-plugins/wmclock/wmclock-1.0.14.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="a dockapp that displays time and date (same style as NEXTSTEP(tm) operating systems)"
+SRC_URI="http://www.bluestop.org/wmclock/${P}.tar.gz"
+HOMEPAGE="http://www.bluestop.org/wmclock/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ x11-misc/gccmakedep
+ x11-misc/imake"
+
+src_compile() {
+ emake CC=$(tc-getCC) CDEBUGFLAGS="${CFLAGS}" LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin wmclock
+ newman wmclock.man wmclock.1
+ dodoc ChangeLog README
+}
diff --git a/x11-plugins/wmclock/wmclock-1.0.15.ebuild b/x11-plugins/wmclock/wmclock-1.0.15.ebuild
new file mode 100644
index 000000000000..f7865e50727b
--- /dev/null
+++ b/x11-plugins/wmclock/wmclock-1.0.15.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools
+
+DESCRIPTION="a dockapp that displays time and date (same style as NEXTSTEP(tm) operating systems)"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmclock"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/dockapps
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog README
+}