summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmcube
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmcube')
-rw-r--r--x11-plugins/wmcube/Manifest1
-rw-r--r--x11-plugins/wmcube/metadata.xml9
-rw-r--r--x11-plugins/wmcube/wmcube-0.98.ebuild44
3 files changed, 54 insertions, 0 deletions
diff --git a/x11-plugins/wmcube/Manifest b/x11-plugins/wmcube/Manifest
new file mode 100644
index 000000000000..53867a2df4c2
--- /dev/null
+++ b/x11-plugins/wmcube/Manifest
@@ -0,0 +1 @@
+DIST wmcube-0.98.tar.gz 38305 RMD160 f987e47044474c69ff5e03afb3dddfd385f545b9 SHA1 30f109a5406fb0cfd0c0ed749212a2a183e5b5f9 SHA256 5111d7bfacc7ffa26419dbc22542a0a0e1d33e5795882d1799b216abd73df24b
diff --git a/x11-plugins/wmcube/metadata.xml b/x11-plugins/wmcube/metadata.xml
new file mode 100644
index 000000000000..14a21e02877b
--- /dev/null
+++ b/x11-plugins/wmcube/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<longdescription>
+wmCube is a dockapp that displays a realtime rotating 3D object and the current
+CPU load. You can design your own objects for it.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmcube/wmcube-0.98.ebuild b/x11-plugins/wmcube/wmcube-0.98.ebuild
new file mode 100644
index 000000000000..139f4976b3e0
--- /dev/null
+++ b/x11-plugins/wmcube/wmcube-0.98.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+DESCRIPTION="a dockapp cpu monitor with spinning 3d objects"
+HOMEPAGE="http://kling.mine.nu/kling/wmcube.htm"
+SRC_URI="http://kling.mine.nu/kling/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ~mips ppc ppc64 ~sparc"
+
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S="${WORKDIR}/${P}/wmcube"
+
+src_prepare() {
+ #Honour Gentoo LDFLAGS, see bug #337893.
+ sed -e "s/-o wmcube/${LDFLAGS} -o wmcube/" -i Makefile
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die "parallel make failed"
+}
+
+src_install() {
+ dobin wmcube
+
+ cd ..
+ dodoc README CHANGES
+
+ SHARE=${DESTTREE}/share/wmcube
+ dodir ${SHARE}
+ insinto ${SHARE}
+ doins 3dObjects/*
+}