summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-23 20:04:44 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-06-26 23:53:06 +0200
commit12c00150130c3b91e443d7ada3a009d1146c2be6 (patch)
tree92f3dbcd89fa5665de5e56c353510b1a53587488 /x11-plugins
parentx11-plugins/bubblemon: EAPI7, improve ebuild (diff)
downloadgentoo-12c00150130c3b91e443d7ada3a009d1146c2be6.tar.gz
gentoo-12c00150130c3b91e443d7ada3a009d1146c2be6.tar.bz2
gentoo-12c00150130c3b91e443d7ada3a009d1146c2be6.zip
x11-plugins/cputnik: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/cputnik/cputnik-0.2.0-r1.ebuild34
-rw-r--r--x11-plugins/cputnik/files/cputnik-0.2.0-makefile.patch4
2 files changed, 36 insertions, 2 deletions
diff --git a/x11-plugins/cputnik/cputnik-0.2.0-r1.ebuild b/x11-plugins/cputnik/cputnik-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..5c123773ab90
--- /dev/null
+++ b/x11-plugins/cputnik/cputnik-0.2.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="cputnik is a simple cpu monitor dockapp"
+HOMEPAGE="https://www.dockapps.net/cputnik"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+S=${WORKDIR}/${P}/src
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin cputnik
+ dodoc ../{AUTHORS,NEWS,README}
+}
diff --git a/x11-plugins/cputnik/files/cputnik-0.2.0-makefile.patch b/x11-plugins/cputnik/files/cputnik-0.2.0-makefile.patch
index 1eb1279b3bb3..b0c39ef2898b 100644
--- a/x11-plugins/cputnik/files/cputnik-0.2.0-makefile.patch
+++ b/x11-plugins/cputnik/files/cputnik-0.2.0-makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2005-03-26 22:29:48.000000000 +0100
-+++ Makefile 2008-01-27 19:43:33.000000000 +0100
+--- a/Makefile 2005-03-26 22:29:48.000000000 +0100
++++ b/Makefile 2008-01-27 19:43:33.000000000 +0100
@@ -1,15 +1,15 @@
-CFLAGS = -Wall -Os