summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-12-05 14:32:55 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2017-12-05 14:39:58 +0100
commit1f49417fd2499f5492f15a1663f8034a3cde7af2 (patch)
tree8bc46dc3410691cc1ae2a6c24dd03815e471d9f4 /x11-plugins
parentx11-plugins/wmcube: 1.0.2 bump (diff)
downloadgentoo-1f49417fd2499f5492f15a1663f8034a3cde7af2.tar.gz
gentoo-1f49417fd2499f5492f15a1663f8034a3cde7af2.tar.bz2
gentoo-1f49417fd2499f5492f15a1663f8034a3cde7af2.zip
x11-plugins/wmtz: 0.7 patchset bump
Fixes compilation failures and updates ebuild EAPI Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmtz/Manifest1
-rw-r--r--x11-plugins/wmtz/wmtz-0.7_p20150816.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/wmtz/Manifest b/x11-plugins/wmtz/Manifest
index b0df331c1cac..0b57371499e9 100644
--- a/x11-plugins/wmtz/Manifest
+++ b/x11-plugins/wmtz/Manifest
@@ -1 +1,2 @@
DIST wmtz-0.7.tar.gz 26350 BLAKE2B c0cad5c7bbca9ddfb8168ef360385305e99298a076e5c317504f646dbf372e1b3af704960a0d3b8e528e3cf97414cc8e3b2cff3d4c37739c81744254411b03f3 SHA512 5de721231c7d7bcccc8a9b962069f4adad85158b39df2e77c6015ed3f24d4f8e43c90f91645e186d7f7c656bc6fb937b435925caff4e55abcfa0a8b0a9e75da0
+DIST wmtz-0.7_p20150816.tar.gz 19310 BLAKE2B 7f3bc0b077a9a667211cc588f1fb7c3d1d246256724a6cf5a17f028d2d334d02f898a798aca6fae11910868d312844bbe8ac5bfd190229f3ae829e97e50e2247 SHA512 60c9b66423332b155ce262d30026a5091c0379eb3257f547af1203d331968e9f334a533ed03832476512893d06cea857db9c044b30115978904510f9725e8455
diff --git a/x11-plugins/wmtz/wmtz-0.7_p20150816.ebuild b/x11-plugins/wmtz/wmtz-0.7_p20150816.ebuild
new file mode 100644
index 000000000000..27ab7640558f
--- /dev/null
+++ b/x11-plugins/wmtz/wmtz-0.7_p20150816.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit multilib toolchain-funcs
+
+DESCRIPTION="dockapp that shows the time in multiple timezones"
+HOMEPAGE="http://www.dockapps.net/wmtz"
+# http://www.dockapps.net/download/${P}.tar.gz
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_prepare() {
+ default
+ #Honour Gentoo LDFLAGS, see bug #337890.
+ sed -e "s/\$(FLAGS) -o wmtz/\$(LDFLAGS) -o wmtz/" -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" FLAGS="${CFLAGS}" \
+ LIBDIR="-L/usr/$(get_libdir)"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ insinto /etc
+ doins wmtzrc
+ dodoc ../{BUGS,CHANGES,README}
+}