summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-11 22:18:48 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-06-14 11:01:08 +0200
commit472aaceb5d67a86d31daa08c7976c61469952fdc (patch)
tree0d09c996cb0107a51b484f1e647b3c128b5b1040 /x11-plugins
parentx11-plugins/wmapm: use HTTPS (diff)
downloadgentoo-472aaceb5d67a86d31daa08c7976c61469952fdc.tar.gz
gentoo-472aaceb5d67a86d31daa08c7976c61469952fdc.tar.bz2
gentoo-472aaceb5d67a86d31daa08c7976c61469952fdc.zip
x11-plugins/wmapm: EAPI7, use HTTPS, improve ebuild
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmapm/wmapm-3.1-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-plugins/wmapm/wmapm-3.1-r2.ebuild b/x11-plugins/wmapm/wmapm-3.1-r2.ebuild
new file mode 100644
index 000000000000..6e795f7937f3
--- /dev/null
+++ b/x11-plugins/wmapm/wmapm-3.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="WindowMaker DockApp: Battery/Power status monitor for laptops"
+HOMEPAGE="https://www.dockapps.net/wmapm"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+S="${WORKDIR}/${P}/${PN}"
+
+src_prepare() {
+ #Respect LDFLAGS, see bug #334747
+ sed -i 's/ -o wmapm/ ${LDFLAGS} -o wmapm/' "Makefile"
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" COPTS="${CFLAGS}"
+}
+
+src_install() {
+ dobin wmapm
+ doman wmapm.1
+ dodoc ../{BUGS,CHANGES,HINTS,README,TODO}
+}