summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-06-10 14:10:26 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2016-06-10 14:10:26 +0200
commit7dd3b1593e0af746436ca116905c6b5e767b38e9 (patch)
treeb3c38c49748f424662caee276825155d4bd317dd /x11-plugins
parentx11-plugins/wmpop3: fix compilation with gcc 5, bug #581718 (diff)
downloadgentoo-7dd3b1593e0af746436ca116905c6b5e767b38e9.tar.gz
gentoo-7dd3b1593e0af746436ca116905c6b5e767b38e9.tar.bz2
gentoo-7dd3b1593e0af746436ca116905c6b5e767b38e9.zip
x11-plugins/wmmaiload: use current SSL connection methods, bug #584082
Reported by Toralf Förster <toralf.foerster@gmx.de> Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmaiload/wmmaiload-2.3.0-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-plugins/wmmaiload/wmmaiload-2.3.0-r1.ebuild b/x11-plugins/wmmaiload/wmmaiload-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..d26569bf49ca
--- /dev/null
+++ b/x11-plugins/wmmaiload/wmmaiload-2.3.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="dockapp that monitors one or more mailboxes"
+HOMEPAGE="http://tnemeth.free.fr/projets/dockapps.html"
+SRC_URI="http://tnemeth.free.fr/projets/programmes/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.1-checkthread.patch )
+src_prepare() {
+ sed -i -e "s/-lssl/\0 -lcrypto/" wmmaiload/Init.make || die
+ sed -e "s/SSLv2_client_method/SSLv23_client_method/" \
+ -i wmmaiload/ssl.c || die
+
+ default
+}
+
+src_configure() {
+ # The ./configure script is not autoconf based, therefore don't use econf:
+ ./configure -p /usr || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ DEBUG_LDFLAGS="" \
+ LDFLAGS="${LDFLAGS}" \
+ DEBUG_CFLAGS=""
+}
+
+src_install() {
+ dobin ${PN}/${PN} ${PN}-config/${PN}-config
+ doman doc/*.1
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS TODO doc/sample.${PN}rc
+}